Showing results for 
Search instead for 
Did you mean: 

SAFEXC-12 communication error between ctrlX IO and ctrlX PLC?

SAFEXC-12 communication error between ctrlX IO and ctrlX PLC?

Occasional Contributor


When we export the real-data in the ctrlX IO it appears the following errors exporting the SAFEX,



I don't really know if it is because of this error but then in the PLC app we cannot find the .xml of the SAFEX,


We are using the last version of the ctrlX IO and PLC (1.12) and we have inserted the xml of the device,

Is there a way to import the xml of the SAFEX to the PLC?



Occasional Contributor

It has been 5 weeks and still no one has replied to this topic...

We are in the middle of an important project so it would be great if anyone could give us an answer related to this,


Established Member


1. the first screenshot is a well known behaviour - it is not a feature its a bug(314259) in the ctrlX IO Engineering. Development is working on it - solving date is not planned yet.

2. The ESI File for the ctrlX SAFETY is not delivered with the ctrlX WORKS Package.
You have to collect it in the Collaboration room: SAFEX-C.1x ESI-File 
Install it into your project into the IO-Engineering.

install ESI file in ctrlX IO Engineeringinstall ESI file in ctrlX IO Engineering

We think you just installed the ESI in the IO-Engineering. For the PLC Engineering yoiu do not need the ESI file.
When the configuration is finnished in the ctrlX IO-Engineering, you have to transfer the configuration from the IO-Engineering to the control.


Afterwards you can fetch the IO-configuration in the PLC-Engineering with the steps:


Then you will see the FSoE and the functional IO from the ctrlX SAFETY in the PLC project.

  1. Background info:
    a) The ESI file for the ctrlX SAFETY is a 2-file ESI - you have to install the marked file (this is the certified ESI)
    The second file with the "Modules" inside is automatically fetched during the installation process with the Basis ESI in the background.
    b) This has to be done on each engineering PC where the Project is used. The ESI file is not packed in the project-backup.


Sorry Eric,

for a long time we had no traffic. We did not look so intensively into this forum. We'll track this now much more tight.

Best regards

Community Moderator
Community Moderator

Just to avoid further questions.

At the moment the ctrlX SAFETY development is not completely synched with the RM sequence for the rest of ctrlX AUTOMATION.

This will change in the future:

  • The releases will mainly come in the sequence of Release Milestones - 3 times a year.
  • Intermediate releases will be patches or partial updates to these main releases.
  • The ctrlX WORKS installation is prepared to integrate the ctrlX SAFETY Engineering in the same way as the ctrlX DRIVE Engineering.
  • The ctrlX SAFETY Engineering will remain a native desktop app, since web-based engineering is no option
    • The SAFEX controllers do not have the ressources to run the Engineering.
    • The effort to port the engineering software is out of all proportion to the benefit.
    • The behaviour is the same as with ctrlX DRIVE, I/O, PLC, no real disadvantage.
  • With every release we will have the full set of device description files (ESI basic + modules for EtherCAT Eth1, GSDML for Profinet ETh2(Uplink)).

The target date for that integration into ctrlX WORKS is not yet defined.

Occasional Contributor

Hello ChrM and Scheurer_F,

We have tried the .xml and the problem still persists,

We can see the SAFEX in the ctrlX IO Software, the problem is that in the ctrlX PLC it does not appear in the "DataLayer_Realtime" and, as a consequence, we cannot communicate between the ctrlX Core and the SAFEX,

Established Member

Same here... I can only get to work until the point, where the C12 is present in the EtherCAT configuration on the coreX but remains in the Pre-OP state with a 0x001E Invalid Input Configuartion Error:


The section, which should include the description for using the C12 with coreX in the installation manual for the C.1x only refers to a document with the description "ctrlX AUTOMATION DOK-XSAFE*-SAFEX-C.1XC-APxx-DE-P". Unfortunatly I am not able to find this very document...

Is there any solution in sight?

Hello ericvergara and plasmotion,

Please try to import the attached file into your ctrlX PLC Engineering project:



Thanks for your reply! I tried to configure the topology with the I/O Engineering tool. Here you file unfortunately doesn't work here. It just tells me, that the file doe not contain anything, that could be imported.

My understanding is that SAFEX-C12 has been added to the ctrlX IO project\configuration then transfered to the CORE. After, the IO configuration should be imported to PLC Engineering by reading online from CORE. This reading online from the CORE is not working or reading the SAFEX-C12. If this is the case the attached files and PDF will help guide you to import the SAFEX-C12 from a file instead of online from CORE. 


Thank you very much, ctrlXProgrammatore,

for giving additional assistance to ericvergara.

I honestly admit, that there are a few obstacles in the process of integrating SAFEX-C.1x into an EtherCAT configuration:

  1. The ESI-File for SAFEX-C.1x is not yet part of the ctrlX WORKS installation, as is the ctrlX SAFETY Engineering. Workaround: Download from Collaboration Room. For access get a Bosch-ID and ask us or your local Bosch Rexroth dealer. Install the ESI-File (as ChrM showed) into the Device Repository.
  2. The device can be scanned, but is not accepted when transfering it into the configuration. Workaround: Add the device to the EtherCAT-Master offline from the Device repository.
  3. ctrlX PLC Engineering and IO Engineering are different tools. The configuration is typically sent to the ctrlX CORE and can be loaded from there.
  4. In some early versions of the ctrlX WORKS there has been a problem with the type of device (fixed slots for functional data, SMMC data, FSoE Master slots (32x), FSoE Slave slot (1x)). Workaround: Export in a version that works e.g. 1.8.0 and import into the current version 1.12.0, where newer ones should not show that problem anymore.

Best regards

Your ctrlX SAFETY Team

Occasional Contributor

Hello ctrlxProgrammatore and Scheurer_F,

Sorry for the delay, we have now tried with the solution that ctrlXProgrammatore gave us and it worked!

We can now communicate between the ctrlX Core and the SAFEX via the Data Layer,

Thanks for the help!


sorry to drag this old topic out of the dirt:
I'm currently trying to configure my I/O engineering and I have a Safex-C.15 controller. And it is not in my parts list to select.

It is mentioned here, that it is not part of the normal ctrlX Works installation. But the provided links, where you could download an ESI-file, are not working anymore. And I don't find alternatives.

Could anyone provide me with a link, where I can get the ESI-File for SafeX-C15?

Thanks in advance!

Occasional Visitor

Hi, I need this ESI File:

......2. The ESI File for the ctrlX SAFETY is not delivered with the ctrlX WORKS Package.
......You have to collect it in the Collaboration room: SAFEX-C.1x ESI-File 

for the connection to a Beckhoff PLC together with ControlPlus.

The AML Export will have this file to finish the RUN in the ControlPlus Environment.

The Link (appears as missing link to "33358678") is not working. 

It's honestly a nightmare that it is so complicated to get ESI Files (in general) from BoschRexroth.




Hello @FrankSwierza1 and @TBauer , sorry for any inconvenience, we are working on the integration into ctrlX WORKS.

the way to the collaboration room is described here. Yes indeed, our whole download area has been running through some changes and some of the links were discontinued.

Once again sorry for the trouble finding the download area in Collaboration Room!

Best regards

Your ctrlX SAFETY team