Showing results for 
Search instead for 
Did you mean: 

EtherNet/IP Scanner of codesys with Ctrlx Core - connection failure errors

EtherNet/IP Scanner of codesys with Ctrlx Core - connection failure errors

Long-established Member


our customer has defined an EtherNet/IP scanner on Port X51 of ctrlx Core using the Codesys communication App.

we noticed during cycle, that we have many connections failures on the communication, 

the customer has 2 EtherNet/IP Slaves, with excatly the same behavior, 

I'm able to reproduce it using XM21 as EtherNet/IP Slave.

we used both 1.12.9 release, and 1.16.1





codesys EtherNet/IP App version : 

do you have more information about this issue ? 




Established Member


for me it is not really clear - there is one screenshot which uses a cfix based scanner,

the other is based on this version.

Which is the one which you use for XM21 as EtherNet/IP Slave. (EIP Adapter)?



Long-established Member



in both examples, it is a an Ethernet adapter (between bracket - Ethernet)

in the example with XM, it just kepts the name of CIFX_EIP due to an update of the device,

in both example it is coming for the app in the collaboration room


I verified that I could successfully configure XM21 as an E/IP adapter.  Sample IW and ctrlX PLC projects and the eds file I used are attached.


Make sure the Ethernet object's network interface is correctly configured.  


It looked like I could create errors similar to yours if I failed to configure this piece correctly.


Established Member

Hello Carl,

Ok it looks good. 

thank you very much.

Established Member


My colleagues have tried your program and it runs perfectly but as soon as they change something (related or not to communication), Ethernet IP communication gets in failure as already explained. If they start from scratch with same settings as yours, Ethernet Communication gets in failure as well. So, they don't understand and can(t find any difference from your sampel and theirs.  

On my side, I've started from scratch with CtrlX Core as Ethernet IP master and HCS01 + XM21 (with engineering port) as slaves.

Every 2mn and 15 sec, XM21 slave trips in Time Out error whereas no communication failure appears with Indradrive HCS01.

Program is done with V1.16 and Ctrlx Core FW is latest one from RM22-07.

Could you try my example and see if I've missed anything?

Many thanks.

I was able to verify your results re: the E/IP adapter attached to the XM21 engineering port.  In my test I made simulaneous connections to both the engineering port adapter and the RT-Ethernet function module adapter.  While the connection to the RT-Ethernet module ran without issue, the connection to the engineering port adapter failed roughly every 2 - 3 minutes for a period of 15 seconds, after which  communication automatically resumed.

XM21_ETHERNET_IP_ENG_PORT_Adapter_Loss of communications.png



(In the test each adapter input image was copied directly to the output image, so in the traces above the expectation was that the two values should be the same minus some some offset due to the communication delay.)

Sample code together with the .eds files used are attached.  This issue will be raised internally.

Community Moderator
Community Moderator


we found out that the behavior depends on the Ethernet IP stack that is implemented on the individual device. This is the explanation, why this works for running the adapter on the onboard Ethernet or the XFE. The issue is addressed to th edevelopment team.

kind regards

Established Member


Has this issue be addressed? I am seeing similar problems with my scanner.

CtrlX 1.18, we have tried the Ethernet Scanner 4.2 and 4.4 from CoDeSys but neither seem to resolve the issue.

Established Member


Yes, this issue has been addressed to development team.

In the meantime, we could find a work around. Basically, after a while, Slave was going in "sleep mode". With some code, we keep it alive and avoid any communication failure (in my case, time-out):

By the way, Ethernet/IP scanner must not be used sinced it leads to EtherCAT issue!!

My inputs on EtherCAT (from IO or EFC or CtrlX Drive stuck at value 0):



This is something also explained in another post: