cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

Scheurer_F
Community Moderator

What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

You are happy since you unboxed your first ctrlX SAFETY SAFEX-C.1x controller,

  • you installed ctrlX SAFETY Engineering to your PC and
  • you powered the SAFEX-C.1x.
  • You connected it via your brand-new XACC-0-USBCx3M Engineering cable and
  • finally the USB connection does not work.

What can be the problem?

4 REPLIES 4
Scheurer_F
Community Moderator

Re: What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

Hello dear ctrlX SAFETY users!

We received reports that there are combinations of PC and USB-cable where the USB connection between ctrlX SAFETY Engineering and the SAFEX-C.1x controller cannot be established, evein if the recommended USB Engineering cable XACC-0-USBCx3M of 3m length (comfortable work in the environment of the cabinet) is used.

The effective problem could not be analysed deep enough until today. It is only a small portion of environments affected.

Until we can provide an actual solution, there are the following workarounds:

  • Try to turn the USB-C connector at the SAFEX-C.1x side by 180 degrees into the opposite symmetric position.
  • Try to use a shorter USB cable of 1m length only or even shorter.
  • If you need the 3m distance, then try to put a USB-hub in the middle or use the USB-ports of a docking station.
  • If even this does not work, then try a different brand or type of PC. (There are indications about some HP computer models being affected.)

In any case, please let us know (the easiest, please reply here! Otherwise please contact your local Bosch Rexroth support technician or sales person!)

  • about the symptoms in your case and
  • the specification/type of equipment that does not work and
  • the specification/type equipment that solved the issue for you.

Best regards

Your ctrlX SAFETY team

ctrlXProgrammatore
New Poster

Re: What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

Hello,

I recently received my first ctrlX SAFEX-C.12/SAFEX-C.15 controls and cannot connect to either one of them with a Bosch Rexroth (US) issued HP ZBook PC via USB. 

None of the above workarounds helped. I was able to connect with a personal Dell Latitude E7440 PC.

Attached are additional details for both the HP and Dell PCs along with a screen clip of the message window when trying to connect.

Thank you.  

ctrlXProgrammatore
New Poster

Re: What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

Hello,

I tried another HP computer (Elitebook 8730w) not issued by the company. It also will not commuincate. Attached are the details. 

Thank you.

Scheurer_F
Community Moderator

Re: What can I do if the USB connection from my PC to ctrlX SAFETY SAFEX-C.1x does not work?

Hello and thank you for your question!

This posting originally addressed hardware problems with the first SAFEX-C.1* samples.

In your case it can be a software issue or just a handling problem.

  • Please check, whether your PC detects a COM port at the moment when you connect the powered SAFEX-C controller or you power it while it is already connected. You should see something like this on your desktop Scheurer_F_0-1628613074323.png.
  • ctrlX SAFETY Engineering cannot detect automatically which COM port is used for your SAFEX-C.1* device. This means for every device you have to set the COM port (shown above) inside the "Connection Settings" below. In my case it is COM10:
     
     

    2021-08-10_16h02_35.png

  • If nothing of the aforementioned steps help, then please check the USB Serial Device driver.

2021-08-10_18h43_28.png

We hope this helps,

Best regards

Your ctrlX SAFETY Team

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist