Showing results for 
Search instead for 
Did you mean: 

Can't connect to Safex C.12 with USB

Can't connect to Safex C.12 with USB

New Contributor

My customer gets this error when they try to connect to Safex C.12 with USB. The same cable works on my computer. 


Safex firmware is  FPGA 211

What can we do to try to fix this? Has there been any progress since this post in 2021?Solved: What can I do if the USB connection from my PC to ... (


New Contributor

My customer's computer is a custom built desktop, ie not a brand name computer. See attached system info.


Established Member

Hi @bclapperton,

Are you trying to connect with an empty project? ctrlX SAFETY Engineering crashes when trying to connect with a SAFEX-C.1x if no device is present on the project.

Best Regards,


OK, I will check it out. With my customer @BRamos.

Hello @bclapperton ,

please provide the configuration on that SAFEX-C.12 controller and save the Exception Information with "Save and Quit" button. What configuration is loaded during the trial to connect to the SAFEX-C.12. It must be either an empty configuration with a SAFEX-C.12 only or the configuration that is already sent to the controller.

Could there be an installation problem that affects the USB connection (e.g. external 24V connected to outputs)?

If you solved it in the meantime, please let us know and mark e.g. @BRamos 's comment as a solution.

BTW: The product's name is SAFEX-C.12, all capital letters. Important to exactly define what is meant and differentiate from competitor products.

Best regards

Your ctrlX SAFETY Team

@Dias , @SaDiego , @MSchEr : FYI

The customer tried several computers. They found that only a private computer worked and all their company computers did not. 

Hello @bclapperton ,

I am completely puzzled with that behaviour.

Does the customer connect via USB or via TCP/IP routed through ctrlX CORE using EoE? In this case we know a limitation in the Bosch network and a work-around for that.

If it works only with a private computer, I'd check the IT Security settings for the USB ports of the company computers. USB usage for mass-storage devices is blocked with a number of companies, maybe even more.

1. Could you please ask the customer to do a video of the connection sequence. Maybe there is something not covered by your report.

2. Could you please ask the customer to use the "Save and Quit" Button and provide us the stored file from the project/configuration directory.

Best regards

Your ctrlX SAFETY Team

@Dias , @SaDiego , @MSchEr : FYI, any idea?


Hello @bclapperton ,

[some added information, 2023-07-28]

Could you please send the information I asked for on 2023-07-23?

I talked to colleagues and received several hints:

  • Please send all data about the device: type plate, serial no., etc.
  • First of all check whether the virtual COM port for a SAFEX-C.1x appears, when you close the USB connection to the powered SAFEX-C.1x. Check whether it disappears when you unplug it or you power down the SAFEX-C.1x.
  • If there is already a problem visible in this stage, please turn the USB-C-Connector on the device side by 180 degrees. In seldom cases the symmetric contacts have not been perfect in the past.
  • Leave the Device interface, get back to edit mode. While reentering Device Interface (online-mode), the list of COM ports is reread. Check whether the expected COMports appear in the selection list of the Connection Settings dialog.
  • If the problem remains, try to leave the device interface and power down the SAFEX-C.1x.
  • If the problem remains, stop and restart the ctrlX SAFETY Engineering.
  • [2023-07-08: If the problem remains, create a default configuration consisting only of  the controller object in the Terminal Scheme dragging in the controller object with V1.0.1.36 selected, if the environment has this setting already. AllAutomation_0-1690556463902.png Save it as a different configuration and try the connection again.]


  • If the problem remains, uninstall ctrlX SAFETY Engineering and reinstall it to a different directory. Make sure the installation process does not show any problems. Document it if possible.

Our colleague @ChrM and @M_Mohann have additional experience, this is why I like to add them to this thread.

Best regards

Your ctrlX SAFETY team


Sorry but my customer is working on other things at the moment. Also, I am about to go on leave for two months. 

However, today I had a second customer email me with the same issue. They can't connect. They were not available today to try to fault find their system. 

Also I found this post.. Solved: Unrecovereable installation of ctrlX SAFETY Engine... (

Is it worth updating to the new system. I can't see anthing in the release notes about the USB connection



Hello @bclapperton ,

Can you send us some information about your deputy.  We can understand the disappointment of the customer and want to free him asap.

There can be nothing in the Release Notes, since it is not known as a broad issue within the users community and there is no clear reproduction scenario for it.

The update to will not help in my eyes. The field update can only be done as announced in the recent Sales Update together with DC-AE/STS since from the IT security (Password to access the device, Secure Mode) is added. The later needs a special treatment:

  • Preparation of the controller with an empty project (controller only) to avoid fatal errors when booting with
  • First step after update is resetting the password to the default

We decided that this should be only done with assistance from DC-AE/STS.

Can you please inform the customers to contact us (me, @ChrM , @M_Mohann or @Dias )

  • mainly to have a look at the failing trial to connect to the USB Device in a teams/Skype or other desk-to-desk conference.

Best regards

Your ctrlX SAFETY Team


Hello @bclapperton and @Tamer ,

In our defect information system I found several reports about connection trials where an exception appeared, but none with the exception-type "System.Runtime.Interop.Services.COMException".

I found several cases, but never with a permanent blocking of the connection:

  • Bug Id #634184 "SAFEX-C.1x: Connection with empty project crashes ctrlX SAFETY Engineering after pressing START" (System.NullReferenceException, V1.7.2.8709)
  • Bug Id #612421 "SAFEX-C.1x: Do not allow connection to the SAFEX-C.1x with empty project" (System.NullReferenceException, V1.7.2.8611)
  • Bug Id #564585 "ctrlX_SAFETY_Engineering stürzt beim connect nach eingabe der Serienummer ab" (System.NullReferenceException, V1.7.1.8238)
  • Bug Id #456424 "Exception ctrlX SAFETY Engineering during online connection - wrong recovery date?" (System.Reflection.TargetInvocationException, V1.7.1.8198)

In one report we see the very same Exception "System.Runtime.Interop.Services.COMException".:

  • Bug Id #342236 "ctrlX SAFETY Engineering | Beim Drag&Drop von Funktionsbausteinen(z.B. EOS) Absturz mit Exception System.Runtime.InteropServices.COMException "Es wird bereits ein Ziehvorgang ausgeführt."" (V1.7.1.8158)

Which Version of ctrlX SAFETY Engineering is in use at customer site(s)?

Do you use a stored and compiled empty project (controller object only inside the Terminal Scheme), before conneting?

@M_Mohann , @Dias , @ChrM : FYI! Any further ideas?

Best regards

Your ctrlX SAFETY team

Hello @bclapperton and @Tamer ,

we have been informed that the customer most probably has tried to connect to the SAFEX-C.12 without any configuration. See Bug Id #612421 !

Best regards

Your ctrlX SAFETY team