Showing results for 
Search instead for 
Did you mean: 

IDE Textual : Missing 'Launch Python in Script Engine' option in debug

IDE Textual : Missing 'Launch Python in Script Engine' option in debug



I'm facing an issue where I can only see the 'Python: Current File' option when trying to run my script in the script engine. I've tried reinstalling both the IDE and Python runtime without success. I also tested with IDE versions 118 and 120, but the problem persists. Additionally, the source control tab indicates 'No repository found.'

Has anyone encountered this? How can I run my script in the script engine properly?



Community Moderator
Community Moderator

Is the ctrlX OS - Python Runtime installed? Could you add a system report (how to) so can get some more insights of your system?

Yes, both the Python runtime and the IDE have been installed. Please see the attached system report.


Community Moderator
Community Moderator

Could you do a test with the current release version 1.20 of the ctrlX OS - IDE app? It can be found in the store area of the collaboration room.

I still have the same problem with both versions.

Hi Parco,

regarding the missing entry "Launch Python in Script Engine" you can try two approaches.

Approach 1:

  1. Delete the launch.json 
  2. Uninstall the IDE App and install it again. (Really uninstall first and not just reinstall)

Approach 2:

  1. Press this button: 
  2. A launch.json should open in which you paste the content of the attached launch.txt

This error can occur when pressing this control wheel button. You should avoid pressing it. We are investigating the root issue and are planing to fix it in the upcoming release.


In your other attached screenshots you showed two additional topics.

  • Repositories can only be found when a .git folder is present. You need to either clone or init one. The activeConfiguration directory is initially not a git repo and therefore none is found.
  • The python error "ctrlx is not defined" indicates a wrong setup for running scripts with local python interpreter. Please follow this instruction: see from yur script that you have e.g. missed to import config and configure it.

Kind Regards