Showing results for 
Search instead for 
Did you mean: 

Model Connect App Error

Model Connect App Error

Established Member

I followed this How-To for the Model Connect app and recieved the following error when building the model in Simulink:

Installation failed: Unexpected error during installation.

[cntrXStateflow_cxcErtTarget] open /var/snap/rexroth-modelconnect/439/cntrXStateflow_cxcErtTarget.zip1659254713/cntrXStateflow_cxcErtTarget/resources/config/config.ini: no such file or directory

I also see an error in the ctrlX Core diagnostic log(attached) that seems to correspond.

Any ideas what could cause this?



Hello bkautzman,

thank you for using the Model Connect app along with the Simulink target functionality. 

The message indicates that in the deployed model zip archive isn't a target-dependent configuration file (config.ini) available.

Did you use the full automatic deployment feature or did you upload the model archive over the Model Connect Web frontend manually?


If you use the manual upload way (e.g. because you didn't have direct access to MATLAB and the ctrlX OS at the same time), please be aware to use the archive which is created by the ctrlXOS_ert.tlc file and don't upload the embedded coder target files (which usually has the extension _cxcErtTargetdirectly.



Established Member

Hello @MarioG,

Thank you for the response!

I tried both the automatic and manual processes. Based on your feedback I was not using the correct file for the manual process. I will have to test this. Any ideas why the automatic process wouldn't have worked?

Hello @bkautzman,

can you please give me some more information what happend by using the full automatic process?

  • Which MATLAB version
  • Which version of the MATLAB addon for ctrlX Automation
  • Which Model Connect version
  • ctrlX COREvirtual or ctrlX X3
  • Model settings (Solver, Stepsize, grt or ert, ...)
  • Diagnostic log

Established Member

Hello @MarioG,

  • Which MATLAB version: R2022a
  • Which version of the MATLAB addon for ctrlX Automation: V0202
  • Which Model Connect version: V-0204
  • ctrlX COREvirtual or ctrlX X3: Virtual
  • Model settings (Solver, Stepsize, grt or ert, ...): I was following the published How-To, so ert and step size of 0.002 
  • Diagnostic log: Attached in initial post

Unfortunately I don't have the required Matlab/Simulink licenses to do further testing. My initial testing was done at a customer site using their installation of Matlab. If you have any suggestions I will communicate that to my customer and see if they have any luck.

Hello @bkautzman,

based on the information you give above i think the problem on your side is that you use two different incompatible versions. Please update your "Support Package for ctrlX OS" to the same version as your Model Connect app. It is advised to keep the Model Connect app and the MATLAB add-on at least on the same minor version. For this purpose, a special folder with compatible versions is available in thecollaboration room Model Connect App 2.4  




Established Member

Hello @MarioG,

Thank you, after matching the versions we were able to build and install the model successfully. However, it did not appear that the model was running and we also couldn't connect to it from Simulink. I'm not seeing the same nodes available in the data layer that were shown in the How-To(Output, Amplitude, Bias, Frequency, etc), nor am I seeing a process in running in the schedueler with a related name. The config nodes in the data layer seem to be set so the model will run automatically and I also restarted the virtual core. Any ideas?

I've also attached the diagnostic log, although I didn't see any related errors.





Data Layer:



Simulink error message when trying to connect to the model: