Showing results for 
Search instead for 
Did you mean: 

IDE APP Problem: Cannot import motion from ctrlxpy

IDE APP Problem: Cannot import motion from ctrlxpy

Established Member


I tried the "from ctrlxpy import motion" in the textual IDE App but failed with 'ModuleNotFoundError'.

And in comparison, I tried with "import time" and it works. 

Here is the screenshot. 


Thanks and best regards,



Community Moderator
Community Moderator

These modules are only kind of header files so that auto completion will work. So only needed for programming. The function itself is bound into the kernel and will work when you run the script on the ctrlX CORE:


EDIT: See DeleopR series two episode 3 how to  for further information. Or see "Collection of How-to blogs and videos for ctrlX AUTOMATION" for all how to blogs and videos.

Hi CodeShepherd,

I have the same trouble so I made that you suggest but now appears this message "NameError: name 'motion' is not defined", do you know what can I do?


Community Moderator
Community Moderator

That is just like expected and is just shown while programming. Please keep in mind that the IDE app only know this function when headers are included. But as you download the script to the control and execute it the core firmware knows this function internally.

Hello CodeSheperd,

I am also having the same issue as Jacks, where i get the error "NameError: name 'motion' is not defined" when trying to run a script in the Texual Editor and having commented out the

#from ctrlxpy import motion
#from ctrlxpy import datalayer


lines. Is there any help for this?

Community Moderator
Community Moderator

Please keep in mind that there are two ways of running a script:

  1. Use the python interpreter of the IDE in your browser. Therefore you need to have the import path in your code because it will really use the function in that libraries.
  2. Use the Python runtime app for interpreting the script on the ctrlX CORE. Therefore you have to explude the import files, like mentioned above, because the function are part of the e.g. motion kernel itself.

You can send me a privat message with some contact data so we can schedule a online meeting.

Hi CodeSheperd,

Thanks very much, sent a PM

Occasional Contributor


Sorry to bring this up again,

I am new to ctrlX IDE and having the same issues.

I select debug and launch python in script engine. 


ModuleNotFoundError: No module named 'ctrlxpy'

Am i doing it right?