cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

0x001E: Invalid Input Configuration - CtrlX Core and SafeX C.12 problem

Filip_K
Member

0x001E: Invalid Input Configuration - CtrlX Core and SafeX C.12 problem

Hello everyone,

I have got problem with connection of the ctrlX SafeX C.12 to the CtrlX Core.

I saw two posts LINK1 and LINK2 but I still can't get rid of my problem.

I have got the ctrlX IO Engineering WRK-V-0116 and ctrlX SAFETY Engineering 1.7.1.8233 versions. I have also uploaded the SafeX .XML file to the ctrlX IO (2022-09-01 version).

I tried to add SafeX C.12 both ways:

1. by scanning for the devices

2. by adding the device from offline database

Then, in both situations I uploaded the configuration to the CtrlX Core and then the problem occurs. There is an error "0x001E: Invalid Input Configuration". Slave can't go in to OP mode.

Filip_K_0-1668513991472.png

Filip_K_1-1668514024416.png

Is there any solution for this problem?

Thank you in advance for your help.

Best wishes, Filip

 

2 REPLIES 2
Polygon
Established Member

Re: 0x001E: Invalid Input Configuration - CtrlX Core and SafeX C.12 problem

I'm having similar problem with C15.

Safex has "empty" project inside (no FSoE slaves configured), but I'm still unable to have EtherCAT bus running. Ethercatmaster has the same error message: "0x001E: Invalid Input Configuration".

Filip_K
Member

Re: 0x001E: Invalid Input Configuration - CtrlX Core and SafeX C.12 problem

I have got the solution for this problem.

With help of Mr. Dirk from the support from Bosch Rexroth DE we managed to resolve the problem.

The reason for this error in my case was the bad version of .XML file that I uploaded to the Device Database in CtrlX IO Engineering.

The version of this "BoschRexroth_ctrlX_SAFETY_SAFEX_C12_C15_ECAT.XML" need to be compatibile with the SafeX Firmware version.

In my case the SafeX firmware version was:

Filip_K_0-1668681630329.png

So I have downloaded and installed the corresponding .XML file:

Filip_K_1-1668681726468.png

Before I used the newest V1.0.1.21 version so that was not compatilible and that's why the problem occured.

After installation I scanned for devices, added the SafeX C.12 and then everything was OK. Both devices are now in the OP state and everything looks good.

Filip_K_2-1668681797863.png

I hope that will resolve your problem too 😉

Best regards,

Filip

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist