Showing results for 
Search instead for 
Did you mean: 

"Bus not running" after loading configuration

New Poster

"Bus not running" after loading configuration


colleague and I are working on getting some sensor input into the ctrlX so we can process it with NodeRed.

However, we're having trouble getting the sensors working, current roadblock is that we can't get the ethercat slave into OP mode.

We're using a CtrlX CORE, linked to it is a WAGO 765 4202/0100 0000.

We installed the .xml according to  this and  this guide; uploaded the configuration into our CORE, however we get this "error":

Bus running.JPG

The configuration we uploaded looks like this:

io engineering configuration.JPG


In the slots we have plugged in:
X01: Balluff 
X02: IMF with IO Link Adapter 

We tried installing the XML files for those two aswell, however when trying to install them in the repository an error would occur.
Another thing we tried is to just get the WAGO Linkmaster running on its own with no attached devices, to no avail, same problem.

We looked up different threads stating similiar problems, but couldn't find a solution that was applicable to our problem (at least we think so).

We also looked into IO-Link compatibility, because the Master is Type B and the Sensors Type A, but our research claimed those should be compatible? (We're rookies)


Thank you very much in advance for your help!

New Contributor

Re: "Bus not running" after loading configuration

IODD of the IO-Link devices is not supported with the ctrlX IO Engineering.
which version of Ethercat Master and ctrlX IO Engineering are you using?
You are using the latest ESI and FW of the WAGO device?

Can you see any diagnosis in the EtherCAT Master or on the WAGO device in the ctrlX IO Engineering online?

May we can have a MS Teams, send me a PN.

New Poster

Re: "Bus not running" after loading configuration


thank you! We will look it up next friday. I am sure that we use the newest versions of the WAGO ESI and all the ctrlX components. WAGO FW is unknown until friday. We did not see any diagnosis online.

I think we could use a MS Teams very well on friday, I will DM you when we know the WAGO FW aswell. 

New Poster

Re: "Bus not running" after loading configuration

Hi cc2go,


I'm snkrieger's colleague.
We're trying to install the firmware on the WAGO device but are running into some trouble:

We can't find the WAGO device in the WAGO-supplied software "WAGO IO-Link Configurator" , neither through the CORE nor by plugging it into out ethernet port and giving it the adress we found through the CtrlX IO Engineering. (We might be in a dead-end here, the software is specified for the WAGO 750 series, but the device we're working on is 765-xxxx)
For clarification: We have little idea of what we're doing, so we just assume that this here is the WAGO device's IP adress:


A question that raised itself here is:
Is the ip-address of the master correct? Is this self-assigned? Do we have to adjust this to our network where the CORE is connected?


To answer your questions more precisely:
We're using EtherCAT Master 1.12.4 and ctrlX IO 1.12.3
The ESI File we're using is V1_1_0_17 (Question: A "diag" file was also included in the download, but we couldn't install it like we did with the other one. Is there anything we need to do here?)
The firmware we do not know, but we're trying to install this one here in case the pre-installed one is faulty / wrong.


Another possible reason for the problem, we can imagine, has to do something with how we're supplying power to the device.
Because of very long delivery time for the L-Coded power cable (most likely because of internal factors, not on WAGO's side) we're currently delivering power to it through a makeshift adapter. I'll not describe it any further, because it runs contrary to any electrical norms or safety procedures :^) , however we're only delivering power to 2 of the 4 pins, and since it's a B-Type IO-Link device, we could imagine that the lack of a voltage on the pins for the (unused) functions of the IO-Link ports keeps the device from entering the RUN status (despite showing the RUN LED) <<[See Edit at bottom].

So if our problem resolves itself miraculously once we plug in the real plug, we know what caused the trouble.

Until then: How can we update the Firmware? We're looking through WAGO documentation right now to see if we can find something there



Edit: The RUN LED on the WAGO device is blinking, which is according to the manual, the pre-run state. Hence the "error" in the initial posting. We're really, really hoping that it's just our little cable issue 😄




New Contributor

Re: "Bus not running" after loading configuration


the EoE settings looking good, to acces via the CORE to the WAGO device you need to set a route. You can check before, that a EoE connection is visible in the CORE Web UI connection settings.
Example of routing and what I mean, you can find in the docu of the EtherCAT Master App:

When a EtherCAT device supports firmware update via FoE, with the CORE runtime and EtherCAT Master v1.16, it's possible to do a FoE firmware update with ctrlX IO Engineering as well.

New Poster

Re: "Bus not running" after loading configuration

Hi there,

we finally got it running. However, we're not 100% sure what exactly was the solution, because we tried many things at once.

Things we did:
Reload the Device-Description-File into our Device. For this, we purposefully loaded a wrong file first, and then the right file again.
We added the route as described in your last post.
We unplugged all devices from the sockets, both phyiscally and virtually.
We set our Slave to stay in INIT after loading all the configurations.

A Firmware update was not necessary.

Afterwards, the Slave did follow into OP-Mode once we put our Master there, and we were able to plug in our Sensors and get our very first readings. Great rejoice!


Thank you very much for your help!