cancel
Showing results for 
Search instead for 
Did you mean: 

WebIQ trenddisplay not plotting graphs

ChickenTeriyaki
Established Member

WebIQ trenddisplay not plotting graphs

Hej,

When creating a graph in my layout, the parameter values do update in the trendLegend, but the trend display itself remains empty:

ChickenTeriyaki_0-1663154250760.png

I have made a data recorder, chosen the right parameters and made a trend to be displayed, but none of it seems to work.

Does it have something to do with declaring an interval for the y-axis? If so, how do I do that?

I have attached the project file, if it can help.

 

Thank you very much.

Tags (3)
7 REPLIES 7
webiq-sk
Occasional Contributor

Re: WebIQ trenddisplay not plotting graphs

Did you set min/max values for each of the recorded values in Process Data Manager? If not the graphs cannot be drawn as the current Trend Display does not have auto-scales. The next version will have that functionality, however.

ChickenTeriyaki
Established Member

Re: WebIQ trenddisplay not plotting graphs

Thank you - I did that - hopefully correctly - now (see below), and it does fix the y-axis.

However the graph still does not update nor plot anything, despite me hitting the 'play' button:

ChickenTeriyaki_0-1663173843495.png

ChickenTeriyaki_1-1663173859051.png

 

webiq-sk
Occasional Contributor

Re: WebIQ trenddisplay not plotting graphs

Can you please send the project?

ChickenTeriyaki
Established Member

Re: WebIQ trenddisplay not plotting graphs

Of course!

I thought I had already attached it in the initial message.

It should be attached here (it is the version before I added the limits as per my last message).

webiq-sk
Occasional Contributor

Re: WebIQ trenddisplay not plotting graphs

None of your items recorded in the trend has any limits set in the app you provided:

webiqsk_0-1663240194310.png

Please note that Input/Display limits are required only. 

ChickenTeriyaki
Established Member

Re: WebIQ trenddisplay not plotting graphs

Like I said, I sent you the version before the added limits, as it was the only one, I had access to at the time.

Attached is, however, the newest version, where I have added limits to all of the variables used.

Still, nothing updates:

2022-09-15_14h08_51.png

ChickenTeriyaki
Established Member

Re: WebIQ trenddisplay not plotting graphs

Here is another, newer copy with almost only the trend widgets

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist