Showing results for 
Search instead for 
Did you mean: 

WebIQ has error activating development mode, licensing agent is not reachable

WebIQ has error activating development mode, licensing agent is not reachable


Hello all,

I am having trouble with opening a project on a CtrlX Core with the WebIQ designer.

The core has the WebIQ server, and OPC UA apps installed, as well as the licenses for WebIQ with 500 tags, OPC UA server and OPC UA client. I am able to communicate to the core through the website/ping/CtrlX works.

I have also set up the shortcut for the WebIQ designer with the extensions for the ip address and port using "--ws-host= --ws-port=10123". When starting the WebIQ app, it begins a series of loading screens: Loading Packages, Activating Work Space and then finally Retrieving License Information at which point it fails (see image attached) stating that the licensing agent is not reachable and to check that the 'WebIQ License Agent is running'. I have confirmed that the License Agent is running on my windows machine in the task manager.

Am I missing a license or have I missed something in my set up of the app?



Hello, did you download WebIQ from the ctrlX store for your local system, i.e. WebIQ Designer, or did you download it from the Smart HMI website?


I installed it via the collaboration room folder for WebIQ on the store.

Can you please verify that the time on your ctrlX is correct and not to set something like 1970?


Yes the Core's time is correct

Hello all,

With assistance from WebIQ, we found that deleting and reinstalling the WebIQ server app on the CtrlX core solved this issue.

I'm having the same issue I followed that form and deleting and redownloading that app. I still got the same error. Any thoughts?