Showing results for 
Search instead for 
Did you mean: 

QtOpcUa: Error when attempting to monitor OPC UA node on ctrlX CORE

QtOpcUa: Error when attempting to monitor OPC UA node on ctrlX CORE

New Contributor

Does anyone have experience with the Qt OPC UA  Viewer application given here?

With this application, using the open62451 backend, I am able to connect to the OPC UA server on ctrlX CORE and read nodes, but I am unable to enable monitoring.  Typical log output is:

Warning: Could not add monitored item for QOpcUa::NodeAttribute::Value of node "ns-2;s=plc/app/Application/sym/UserVarGlobal/Value" : BadInternalError

This issue is not present on other OPC UA servers that I have tried, including the server on XM22 (14VRS firmware), the sample OPC UA C++ Demo Server (Windows) available from Unified Automation, and the public simulation server available here from Prosys.  In these cases I can connect and enable monitoring successfully.  See attached videos.

UaExpert connects and monitors nodes on ctrlX CORE successfully and I have tried to implement the settings used there in my Qt OPC UA Viewer source -- all to no avail.  See images below.



The ctrlX CORE server settings and debug output verifying the monitoring parameters are attached. 

If anyone can shed light on this issue, it would be greatly appreciated. 

Qt 6.4.2; open62451 Git-Revision: v1.1.2-8-ge941fc23; OPC UA Server app 1.18.1


Established Member


this issue was not known before. To analyse the problem we require in best case a wireshark record (with non-encrypted traffic) and also a trace records of ctrlX OPC UA Server. Before activating trace please set in DataLayer the opcuaserver/trace-configuration/facilicty-mask to 8388599 and the opcuaserver/trace-configuration/trace-level to 511. To activate trace please set trace/rexroth-opcua-server/units to (true,true,true), before starting the connecting with the client. After the try to monitor, just download the logbook over ctrlX WebUi using the following configuration:



Please provide the downloaded logbook and wireshark record here or directly as private message to me.



Requested trace and Wireshark capture files are attached.

Some additional info: I had created a user token for Policy=NONE.  Deactivating this and reactivating the user token with Policy=BASIC256SHA256 seems to have solved the problem.  See attached video.

Screenshot from 2023-02-06 10-34-51.png

Established Member


thanks for your additional information. That was the hot tip. We can reproduce the issue for connections using None UserName Token. That is independend from the client. In this case no subscription are possible. Please notice that the most of the client using the best encrypted UserName Token, even you select a none secure endpoint. In this case it is possible to subscribe sucessful.

We already identify the bug and will bring a fix in the next release.

Thanks for your bug report and your investigation.