Showing results for 
Search instead for 
Did you mean: 

ctrlX WORKS Virtual Error: Failed to find an available Port

ctrlX WORKS Virtual Error: Failed to find an available Port


Hello everyone,

i want to start a virutalcontrol in WORKS, but I always got the message which you can see in the screenshot. 


I tried in Advanced Options the Network Adapater and the Port Forwarding. The Version I use:

Installed version: ctrlX WORKS WRK-V-0104.0 (1.4.0)

Tried it on a Windows 10 64Bit computer with admin rights.

Sincerly Yours,



Community Moderator
Community Moderator

Please check following points.

  • Deactivate VPN
  • create a new virtual control in the network mode "Net-Adapter"
  • Check if there is any virtual Control Adapter installed at the net configuration of the PC


  • Activate the virtual process monitor window in the ctrlX WORKS configuation and check the message of this window when you start the virtual control.


  • Start the virtual control
  • If you have again problems make a screenshot of the QEMU monitor window and post it here.



I'm having the same issue, see screenshot here:

Screenshot 2021-05-06 105141.png

I tried the steps described above but sadly that does not seem to have fixed it.

I've seen the QEMU window appear once very briefly but not long enough to see any output. Right now, starting will the virtual control will show a `Booting` state for a second, then revert to `Offline`. The QEMU window itself does not show.

Other things I've tried, all without any changes in behavior:

  • switching between the Network Adapter and Port Forwarding modes
  • rebooting the system
  • deleting and re-adding the virtual control

Is there another way to gather more information, e.g. system logs, etc. to diagnose the issue?

Community Moderator
Community Moderator


we need some mor infos:

1. Please add some informations about you environment. CPU-Type

2. Do you use Port Forwarding with you ctrlX CORE virtual?


If yes add your port assignment here.


3. please check the active ports in the system. Open command window and insert command "netstat". After pressing "Enter" a list of the currently used ports will be displayed.



`netstat` put me in the right direction.

Apparently, the Nvidia display driver software starts a service `nvcontainer.exe` that, among some others, binds port 65001. I was able to disable the service temporarily and can now start and access the VirtualControl as expected.

This is more of a temporary workaround, though. Is there a way to change the default port configuration so that this collision no longer happens?

Long-established Member


Sorry, the 65001 port is up to now fixed, as it is an internal communication channel. We will try to check for the availability of the port and create dynamic internal ports.