Showing results for 
Search instead for 
Did you mean: 

Cannot run Virtual ctrlX anymore in ctrlX Works. "No hardware acceleration was found"

Cannot run Virtual ctrlX anymore in ctrlX Works. "No hardware acceleration was found"

Long-established Member

When using ctrlX Works I find my virtual ctrlX runs extremely slow with errors. Before it runned smoothless.

Checking ctrlX works settings I find the following messages.


Trying to install the HAXM again failed (this option is mentioned in the error message). System requirements are not okay, but that seems strange to me while it worked faultless before. I did not change anything.


In the installation file of HAXM there is a check tool. It tells me VMX is not supported. But it should be supported as in the example left.


My PC is managed by the organisation and sometimes I get updates. Maybe this has something to do with it. 

What could be the problem here?





Long-established Member

I found that the Virtualisation Based Security caused the problem. It did not allow me to re-install HAXM. 

With disabling the VBS my problem was eliminated directly !

To check the status of VBS-

Go to Search → System information → Virtualization based security ( Status should not be running )

If VBS is running and you want to stop it.

Option 1

Step 1 -   Open Windows Powershell as administrator

NOTE: You need (temporary) admin rights.

Execute the below command in cmd.exe command prompt, PowerShell, or using the Run feature.

powershell Start-Process powershell -Verb runAs

This opens the powershell console as an administrator.

Step 2 -   Download and run the script using Windows Powershell

Download the disableVBS-file (attachement) and save it in file explorer

Browse to the location you stored the disableVBS-file in File Explorer and copy the path from the file into the Administrator: Windows PowerShell opened  in the first step.

Press Enter to continue.

if you see output :

  • Reboot your computer to apply the changes
    • Restart your computer and check if VBS is running or disabled after the restart.
  • Disable Hyper-V in Windows features and run the script again
    • Search for " Turn on/off windows features " and uncheck Hyper-V from the list (you need admin rights to perform this action)
    • Reboot your computer to apply the changes
    • Re-run the above txt file (repeat step 2)


To Verify VBS is running or not ,

  • Go to Search → System information → Virtualization based security ( Status should not be running )


If the first option is not working follow the option2


  • Please run the below command in command prompt. Run the command prompt as admin.
    bcdedit /set hypervisorlaunchtype off
  • -> Reboot the system


On My PC I had to use option 2

Long-established Member

I made a video of it.

The checktool you can find in the installation folder 

C:\Program Files\Rexroth\haxm-windows_v7_7_0

(I made a copy and put it directly on C:)

Long-established Member

I found the root cause of the problem. Looking at my Network settings I saw the Hyper-V switch enabled every restart.


Instead of stopping the Hyper-V manually I wanted to delete the Hyper-V permanently.

While my computer is managed by the organisation I had to arrange that over the central IT-portal



Problem was permanently solved