cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

ctrlX PLC Engineering does not work as intended after upgrading from 1.12 to 1.16

asif_HF
Member

ctrlX PLC Engineering does not work as intended after upgrading from 1.12 to 1.16

Hello ladies and gentlemen,

As per stated above, ever since me and my team updated our ctrlx Core and ctrlX Works from 1.12 to 1.16, alot of bugs and error have been occuring as of lately and this is one of it. In ctrlX PLC Engineering 1.12, we can still addthe POU, SYMBOL and VISUALISATION, but as for v1.16, as you can see in the image provided below, none of those no longer exist making any previous plc program ever created on on the previous version unreadable due to those items not being there.

We have tried alot of things including install-uninstall, and repair but so far we got no luck on our side as the problem keeps on popping. We also tried to use previous or make a new program which prove futile due to the non-existence of those 3 things mentioned as we really2 need them to be used in plc program. Can anyone have an idea of what is actually going on or perhaps a solution or workaround on this? We really appreciate the help as this project is rather crucial for us.

2022-09-23_17h02_43.png

 2022-09-23_17h10_35.png

3 REPLIES 3
georkueh
Long-established Member

Re: ctrlX PLC Engineering does not work as intended after upgrading from 1.12 to 1.16

Hi,

have you already updated the ctrlx CORE Device in the project to 1.16? Could you add a screenshot of the Placeholder dialogue in the case the errors are displayed?

kind regards

asif_HF
Member

Re: ctrlX PLC Engineering does not work as intended after upgrading from 1.12 to 1.16

Hi and thanks for replying. From your 2 questions, firstly yes I have updated the ctrlX CORE Device in the project to 1.16 and especially if you load it directly from ctrlX core PLC, by default it will definitely be 1.16 as the image shown below. As for the number two, attached below are also the screenshots of the Placeholder dialogue errors which are being displayed. I have tried to load a different project version, but the error is still the same as if like upgrading to 1.16 making all previous available library gone(even after uninstall-reinstall).

 

Best Regard

2022-09-26_09h11_11.png

 

2022-09-26_09h06_44.png

 

2022-09-26_09h16_26.png

Tags (1)
asif_HF
Member

Re: ctrlX PLC Engineering does not work as intended after upgrading from 1.12 to 1.16

Nevermind, I finally got to solve it. What I noticed was when I updated the ctrlx PLC Engineering, what it did was it overwrite old library(the v1.12) making it corrupt and unreadable hence thats why the error/unidentified notification keeps popping up. After I uninstall and delete everything related to ctrlx works(the directory folder in C) and reinstall it, I finally get it to work as image shown below.

Just incase if anyone got similar problem, What I did specifically are
using uninstall manager>uninstall ctrlx works>opens <C:\Program Files\Rexroth>  n delete whats left including the rexroth file folder>restart computer>reinstall ctrlx works v1.16>during installation, I didnt tick anything else other than the one it was defaulted>done installing, launch ctrlx works>launch ctrlx core webpage and launch ctrlx plc from it instead of from ctrlx engineering>once its launched, set all to newest and everything is now back online and good to go.

(do note that project archive of plc ctrlx project program[default folder my Document] was being cleared 1st as in removed to another place just to be safe and do not do anything else while re-installing because sometimes it crashed and have to start all over again)

Best Regard2022-09-26_12h31_40.png

 

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist