Showing results for 
Search instead for 
Did you mean: 

PLC stuck in Run. Actions Stop, Online Change, Download, Reset are blocked

PLC stuck in Run. Actions Stop, Online Change, Download, Reset are blocked

New Contributor


My customer ran into a strange situation with CORE X7/CtrlX WORKS 2.04. They made a minor change to the logic and tried to do an Online Change but they got this error:


I did a remote session with them and we tried many things including restart PLC Engineering, restart X7, new PLC project but kept getting this error. From the Web UI we also got errors when trying to Stop or do Reset Origin (see below). We could still login with PLC Engineering if we go online without changes. But the PLC was stuck in RUN. We even went into Service mode, uninstalled and reinstalled the PLC app, back to Operation Mode but we still ran into the same problem. Note: deleting PLC app doesn't seem to delete the PLC data (boot project etc.). Is there an easy way to do this? Or we have to manually edit file system or archive file?


Ultimately they did a Factory Reset and restored previously saved App Data .zip to recover.

Best regards,




Community Moderator
Community Moderator

First way to erase data is, like you tried, reset origin. Did you also try to execute this command via the ctrlX PLC Engineering?

The files not getting deleted is intended to be able to e.g. change version without loosing data. If first solution is blocked you can delete the PLC folder in the active configuration or the configuration archive.

We will try check for the problem shown. Could you provide a system report (see how to) in erroneous state?

New Poster


Have you checked the operating mode in Engineering? It sounds like operationmode is locked. I think you need to be online to see the status of the OpMode.