Showing results for 
Search instead for 
Did you mean: 

Node-Red unable to install pallete

Node-Red unable to install pallete

New Contributor

Hello Community,

We have 17 brand new ctrlX unable to install Node-Red pallete. (see below)

We are getting error "Failed to load node catalogue" for all 17 units.


We tried version 1.16 and 1.18 but still no avail.

I have tried our demo unit is working fine but the brand new ctrlX has issue.

Anyone had this issue?

Attached is the system report.

Warmest regards,


Community Moderator
Community Moderator

Hi Open, 

Please beware that your ctrlX CORE has to be connected to an open internet to be able to download a palete in Node-Red. Besides your ctrlX CORE, also your engineering PC has to have internet connection. Please also take a look into the date and time settings on the ctrlX CORE, to see if the time is set correct, this can also be an issue. 

This community member also had a similar problem: Node Red issue installing palete

Best regards,


New Contributor

Hi Nick,

Thank you for your reply,

I have resolved the installation of node issue,

I am using bosch laptop therefore i do not have access to internet. i then use another pc with internet access and it worked.


I am facing another issue, i can install Influxdb and Modbus node except node-red-contrib-aedes. 

When i use localhost node-red and install node-red-contrib-aedes 0.11.1 it can install but in ctrlX i could not install.

When i use my demo ctrlX unit i cant update node-red-contrib-aedes node from 0.9.0 to 0.11.1

Anyone is facing this issue?