Showing results for 
Search instead for 
Did you mean: 

Cannot find device description files for C15 and use EFCs

Cannot find device description files for C15 and use EFCs


I'm also having troubles with ESI files...

The linked package does not include the SAFEX-C.15 Moduls and I can't find them anywhere! 
Could someone provide a link to get those?

Also I have a Frequency Converter (R912007274) with a Multi Ethernet Protocall card (R912006134). I found the - supposed - ESI file:
But when I try to add the ESI file to my I/O repository it says, that the file is corrupt! Could anyone check if that problem is on my side or the file is actually broken?

Thanks in advance for information/links!


Community Moderator
Community Moderator

Moved to own topic from this one.

@TBauer Adding the EFCx610 device description file "ESI-v1.0_BoschRexroth_xFC01_CoE_20201021.xml" that can be found at your link to my device repository in ctrlX IO Engineering 1.18.0 and 1.12.10 works fine on my side. Which tool in which version do you use?ctrlX IO Engineering EFC in device repositoryctrlX IO Engineering EFC in device repository

We will check for the C15.

Ok, little update for that:
I found out, that the C15 file is "hidden" in the collaboration room.
I think I stopped reading when I got to the "FPGA" part in the folder "Runtime_Firmware". But you find the configuration files there. Personally, I would have searched for that in "Engineering"! 

For the drives ... I admit, I'm confused. I wrote the official support and they wanted to know what error message I get. So I tried to install it again and ... it worked! Not sure what my PC did wrong before! 

So, I'm fine for now! Thanks for the replay though!