Showing results for 
Search instead for 
Did you mean: 

Workaround for delaying startup of HMI on WR panels

Workaround for delaying startup of HMI on WR panels

Long-established Member

I've made a workaround for that the WR panels boots faster then the core.

Download this file. Edit the url and startup delay inside the file, then put this file in the download folder in the hmi using a USB stick.

Then change the url in the panel to the local html file:


And now it should show this file for a while before redirecting to the core's hmi


Frequent Contributor

If you want to simply call an action after 30 seconds you can simply use setTimeout 😉 

setTimeout(function() {
    location.href = url;
}, delay * 1000);

Long-established Member

But with my solution its possible to add an "Starting in 30 seconds.." function, and that could be usefull.

Established Member

Hi @AndreasL 

I am trying to implement your solution above but cannot get the WR panel to recognise my USB device.  Is there another method like FTP I can try to get the files on there?

Many thanks

Long-established Member

Not as far as i know, is the usb formatted as FAT32? 

Established Member

Works for me, thanks Andreas.

Established Member

Hi Andreas,

may I have question regarding your workaround?

1) I have tested the code you provide and I had to modify a code a bit to:


Without the modification I always get syntax error in my web browser (I do test on my PC). What was the meaning of your original code - I haven ´t found any example on internet for it?

2) According help it seems that setInterval calls function continuesly and never stops till you call clearInterval function.


Shouldn´t we call the clearInterval inside IF then? But it´s true that we do not have any variable for ID created for our function.

As soon as I open startup.html in my browser, after 10 s it starts opening new windows with my target url -> therefore I´m asking whether it is ok or not.

Thanks a lot for clarification.





Long-established Member

1. The () => is an arrow function, it works in all major browsers unless you run an ancient version (And then you really should update due to security fixes):

2. The line window.location.href will clear the timer and then redirect to the WebIQ page, so no need to clear the timer.




New Poster

Hello Andreas, I have tried to implement your workaround and have the following problem:

The WR21 freezes while beeing in the delay. This is evidenced by the fact that the wheel no longer turns after a few seconds. The Panel than needs to be touched a few times so that the Kiosk App shows that it has crashed.

Have you ever heard about this behaviour? Do you have a suggested solution?


Long-established Member

No, thats new, are you using the new RC7 update for the panel?

I have made an update that I have received from BR, but I am not sure if it is the RC7.

The current build is ... 20221122.172517 ...

Edit: Updated to RC7 but now it is not possible anymore to enter the path to the startup.html file.


Is there some limit for delay value? My ctrlX Core X3 starts more than 100 seconds. The solution with delay of 30s works for me, but is useless, because after 30s is the PLC still booting. When I tried to increase delay to 90s, the Webstation waited requested time, but then displays only completely blank screen. It is not frozen, Webstation runs, I can exit from it properly.

Recommended FW update to RC7 didn't help and moreover, now it is not possible to edit URL in Kiosk app... dialog shows: Invalid URL.

Thanks for any hints.

OK, so with FW RC7 is no workaround needed anymore...

There is new checkbox in Webstation URL entry dialog: Update

When you check it, you enter reqiured reconnect interval and OK. After restart, the Webstation tries periodically connect to entered URL.  👍

Hello have a similar topic with WR21 connected to X3 WebIQ:
X3/WebIQ starting up more slower than WR21. I have updated the WR21 to RC7 and use the "update ineterval option" too. The update interval tries to connect the IP of the X3 (not the WebIQ port - I suppose). 
When the X3-IP is reachable the update interval get connected to the control with Error 404 and goes finished without any new try of reconnection.

Is there any option to change the URl of the update interval function of webstatation (to the URL of WebIQ)? Or can I do anything on site of X3 to delay the enable of the ethernet connection (until WebIQ is ready)?


Long-established Member

See here the workaround for version RC7:

I've made a replacement WebView app with a configurable startup delay and SSL certificate error ignoring.

All screenshots are taked using the RC7 update:

Download and put the apk file on a usb stick, plug it into the panel


Install the app by double clicking on it, say yes on the two messages


When the app is installed, close the dialog and open the "Kiosk Settings" app, then click the small arrow and press "Select The Apps"


Select the WebView app in the list:


Then mark the WebView app in the Kiosk and press the "LOCK & LAUNCH" button


At the first startup the app will show a settings where you can enter the url, startup delay, settings password and change the background color:


Press the back and the loader should start counting down.


If the view fails to load after the timeout the timer will restart and try again.

Long-established Member

The viewer was not clickable, fixed in the version 1.0.1

Established Member

WebView works well but can not open Virtual assist since does not support WebGL. also does not like much iframe from webvisu. kicks you out and starts the coundown again