Showing results for 
Search instead for 
Did you mean: 

CtrlX X3 Core 2 stock at 100% Load

CtrlX X3 Core 2 stock at 100% Load

New Poster


I am using The PLC-App Version 1.20.4 with System image X3_01.20.9

For reasons i cant explain core 2 is always on 100% load which causes the core to switch to service mode without possibility of restarting.


Only Factory reset or Backup bring core back up and running.


Any Suggestions on where to look?


Thanks a lot




New Poster

Some additional Screenshots


Now running with every source code inactive (// used to comment everything out), still 70% load without any PLC-Code running



Occasional Contributor


Based on your screenshot of the system process performance, it looks like your datalayer is being overloaded with broker requests.

What other apps are you running on the system? Are you polling the datalayer at a fast rate, and/or at many endpoints, from some application?

I am running the motion app, profinet device and the plc app.


Codesys Webvisu connected from 2 points


Occasional Contributor

At this point, it will be difficult for me to troubleshoot without the configuration and code of your other system apps. Based on the screenshots you showed, my bet would be there is a piece of PLC code that is polling the datalayer intensively. What is the update rate on the WebVisu variables? 

You could take a backup and then uninstall the PLC application to see if that is where the problem is originating. 

My HMI is set to 100ms,

Main Task and Motion Task are set to 2ms.

I am just confused why everything is running on Core 2, Its an Multicore PLC and Core 3 is Realtime as well. So it would be great to simply put the motion part on core 3 and Main task on core 2.


I think that would already help a lot just by splitting the load, using the existing cores.


Anyway to do so?


Occasional Contributor

Yes, this is also possible using the scheduler configuration within the ctrlX OS. I do still think the load on the datalayer is much too high based on the application you are describing. I would suggest looking for the root cause of this.



Community Moderator
Community Moderator

PLC Tasks in standard are running on core 2 but with an multi core license available you can shift it to any core you like:

ctrlX PLC Engineering - multi core task settingsctrlX PLC Engineering - multi core task settings

ctrlX CORE WebUI - scheduler settings with PLC multi corectrlX CORE WebUI - scheduler settings with PLC multi core

But I agree to @Sgilk you should check out what creates the load to your data layer and also check which load is created by your PLC tasks.

Thanks for the feedback.


I totally agree that finding the the reason would be the best way.

Unfortunately I am right now very tight on timeline.

As soon as I have some spare time ( product is in Pre-Testing) I will look into it and post updates here.


Thanks a lot

 Just to keep you updated.


I finally had some time to look deeper into the problem.

For a reason I still dont understand, the high core load was created by a very simple programm which just converts pressure.


I copied the source code in a new program, deleted the old one and afterwards loaded it into the core.

That solved the issue.


Everytime i tried load the original program, the load rised to 100%.

Using the same source code copy pasted into a new program and the core load is stable at 70% ( which is ok for me)


So I found the part of my program that caused the load issue but unfortunately I do not understand why that program creates 100% load.


The same code in a new program creates no issues...