Showing results for 
Search instead for 
Did you mean: 

License is not working on WebIQ Server


License is not working on WebIQ Server


I have two different ctrlX Cores with the same configuration. On one controller, everything is working fine (IP and on the other controller, the WebIQ Designer is not recognizing the License on the server.

The attached Screenshots:

noLicense.png: it´s a screenshot of  and  

licensing_page.png: Screenshot of both licensing pages. on both ctrlX Cores is the license activated.

The system time is set on both controllers, so this could not be the problem.

I tried several reboots and reinstalling of the apps, nothing is working. I also compared the versions of the apps and both are the same.

WebIQ: 2.10.0

Core18: 20210611

Automation Core: 1.12.2

I have no more idea, why the license is not working on my controller.

Established Member

Re: License is not working on WebIQ Server

Hey, have you installed the licence over the capability response file on th coreX?

Please check, if you can check it in the licence manager (for me: If you do not see any corresponding licence, you have to go to the licensing center (fist icon in the image below), check the licenses and create a capability response. after downloading the file, just upload it to the core (middle icon in the image below).


Worked for me at least... Good luck!



Re: License is not working on WebIQ Server

Yes, the license files are uploaded on both controllers.

You can see in the screenshot:


I can not see any differences in version, license, ... on both controller. 

Anyway, WebIQ Designer is not recognizing the license and therefore i can only use 1 of 2 controllers.

If noone has any further ideas, i will install my ctrlX Core with a brand new image and will try it again. But then, there is no more troubleshooting possible to solve this error in future.

Community Moderator

Betreff: License is not working on WebIQ Server

Maybe it depends on the order of installtion. I talked to a collegue who had the same problem. - He first installed the snap - Then the installed the license. License is not working in WebIQ. After deleteing and reinstalling WebIQ snap the license is working.
Community Moderator

Betreff: License is not working on WebIQ Server

We found a license bug in ctrlX V1.12.7 (RM21.11.6)

  • - When the "temporary usage rights" are active, the WebIQ (an maybe other licences are not valid anymore).
  • - This option is available on Settings>Licenses>Gear icon in the upper right corner. .
  • - The only way to disable this "temporary usage rights". Reset the ctrlX with a image update.