Showing results for 
Search instead for 
Did you mean: 

Method https has died unexpectedly - apt error

Method https has died unexpectedly - apt error

New Poster


When trying to run apt update or apt-get update, I get the following error:

boschrexroth@app-builder-amd64:~$ sudo apt update
Reading package lists... Done
E: Method https has died unexpectedly!
E: Sub-process https received signal 4.

I'm not sure why this is occurring as I have been able to use the SDK properly for a few weeks now, and have made some python and c++ apps. It was only when I tried running the bash script that I started getting this error.


  • I have confirmed internet connection
  • I have tried clearing the /var/lib/apt/lists/* files
  • Sometimes it seemed to work when I cleared any files from the /etc/apt/sources.list.d directory, but other times it doesn't.
  • I have tried updating the lines in /etc/apt/sources.list to use the mirrors protocol
  • I have tried setting the GNUTLS_CPUID_OVERRIDE environment variable to 0x1
  • I have tried building a brand new app build environment and testing it in this one


The error I get when running ./


I'd really appreciate any help, thanks.


Community Moderator
Community Moderator


I tried to reproduce your error, but was not able to do so. I created a new Build Environment (with ctrlX WORKS V1.20) and executed the scripts "" and "". The scripts got executed without an error and also "sudo apt-get update" works afterwards without an error for me. 

When I look at your error message, I can only recommend the things you already tried.  

Which version of ctrlX WORKS did you use, also the latest V1.20? 

Hi Nick,

Currently I have version 1.18.1 installed.
I just tried creating another app build environment and tried running ./ and whenever

sudo apt-get install

is run, I get the error in my original post.

Does my PC have to be connected to the CtrlX to install the app-build environment / run the install ^ command? The VM is installed onto the PC right, so it shouldn't have to.


I have also tried searching for v1.2 but could only find this version on the CtrlX Store page (v1.12.10)



Community Moderator
Community Moderator

I would recommended you to try it with the newest version (V1.20) again. In this version you will also get notified after the first boot in case something did not get setup correctly in your App Build Environment. Maybe this can already give you some hints. 

Yes you are right, the App Build Environment is independent from the ctrlX CORE. You don't need to be connected to a ctrlX CORE to work with the App Build Environment. 

The Early Adopter Release (like the V1.20 currently, till end of July) you will get from a different folder in the Collaboration Room. See my screenshot: ctrlX WORKS in the Collaboration Room at the path: ctrlX AUTOMATION/ctrlX CORE APPS Releases/V1.20/ctrlX WORKSctrlX WORKS in the Collaboration Room at the path: ctrlX AUTOMATION/ctrlX CORE APPS Releases/V1.20/ctrlX WORKS


If you are not able to see this location please have a look at the FAQ for ctrlX Store and request access to "access level 3".