Showing results for 
Search instead for 
Did you mean: 

Problem with Virtual CtrlX Core

Problem with Virtual CtrlX Core

New Poster

Good morning,

I have a problem with the Virtual CtrlX Core.
When I try to start it, the element "Offline" turns to "Booting" but nothing else happens and after some time (fews seconds to one or two minutes), it turns back to "Offline".
We tried to look at the emulation process window by activating it in the seetings but it doesn't launch.
I tried too to reinstall my full software but it still doesn't work.

Configuration :
- CtrlX Works 1.18 on a real computer
- With Network Adapter or Port Forwarding

Thanks for your help.


Established Member


I have had the same issue and as a temporary solution you can get around the problem by running ctrlX WORKS as administrator. Does that work for you as well? 

This is only a quick-fix to not get stuck but hopefully someone can update the thread with the root cause of the problem.


Thank you for this workaround.

It looks to work for me too as an administrator.

Hi again Quentin56,
I think I have solved the problem permanently on my side. Unfortunately I changed several things at once and can't pinpoint exaxtly what fixed it (😅), but it seemed to be an issue of read/write permissions of the data stored in the ProgramData-folder. 

My prodecure was:

  1. uninstall ctrlX WORKS
  2. remove the folders:
    C:\ProgramData\Rexroth\ctrlX WORKS
  3. reinstall ctrlX WORKS

However, I do believe that only removing the "TrustedStorage"-folder and restarting ctrlX WORKS could fix the issue - I traced another fault to this when not being able to open settings -> licenses without admin rights. If you try this, please get back with an update in this thread 😊
// Daniel   

there was an issue regarding the access rights on the trusted storage folder. In 01V20 and newer we fixed this and decoupled the virtual controls from the trusted storage folder.