cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

Configuration does not load PLC correctly

Luschuerz
Established Member

Configuration does not load PLC correctly

I tried to copy a plc configuration to an empty configuration in order to test remote plc configuration via the remote agent. I keep getting the same error when trying to load the configuration into an empty CORE.

Steps I've taken to try and copy a configuration.

  • Set up a PLC Program in PLC Engineering on an existing CORE.
  • Test if the program is running correctly
  • Save the configuration to active configuration
  • Download the saved configuration
  • create a new empty configuration and activate it
  • Check to see if the PLC Program is gone
  • Create a new Configuration
  • Load the previously downloaded configuration into the newly created one
  • Activate the uplaoded configuration

 

I keep getting the same error: Failed to load PLC runtime. 

Luschuerz_0-1601477801553.pngLuschuerz_1-1601477995943.png

 

Rebooting the CORE does solve this issue as the Configuration then gets loaded correctly and I can run my PLC Program. However if I want to configure PLC Remotely rebooting the CORE every time a configuration is changed is not an option.

 

Any Idea?

2 REPLIES 2
CodeShepherd
Community Moderator

Re: Configuration does not load PLC correctly

This is an already know issue in the actual version of the system. We are working on this.

The actual recommendation is to restart the control after each load of an configuration.

Luschuerz
Established Member

Re: Configuration does not load PLC correctly

Another Solution is to disable and re-enable the PLC App. The Programm will then get loaded correctly as well.

This can be done with remote access and can be a work-around until the configuration is working properly.

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist