Showing results for 
Search instead for 
Did you mean: 

EFC communication with ctrlX CORE. EFC stuck in pre-op after adding a telegram

EFC communication with ctrlX CORE. EFC stuck in pre-op after adding a telegram

New Poster


I have a test project using COREX-C-X3-11-ANNN-21.01-01RS-NN-NN with EtherCat master version 2.2.0.  When the EFC is configured with using the Rexroth mode with default 2 input words & 2 output words then everything seems to be working without an issue.  The problem is EFC does not come out of pre-op mode when additional telegram is added to the telegram (added addtional telegram using Expert mode).  After addtional telegram has been added then download new IO configuration and update the PLC program.    ctrlX Core master EtherCat status is OP but the EFC is stuck in "pre-op".   Even cycling power to the entire system still not fix the issue.  Once redownload the default configuration then the communication works again so it seem unlikely due to hardware issue. 


Community Moderator
Community Moderator

Could you give us some more information:

  • Which parameter you did add?
  • Are they even usable in cyclic communication?
  • Is there an error message at the EtherCat master (e.g. drive parameter wrong)?
  • Which firmware version of the EFC and the multi ethernet extension (MEP) is used?

Added parameter(s) were selected from I/O Engineering drop down menu.  Tried parameters were typically "d0.xx" diagnostic parameters.  For example, I have tried d0.0, d0.1, d.12, d0.13......  Configured parameters were shown in the PLC engineering data layer after downloading to the Core.  EtherCat screen show all devices status with green circle with a check mark.  EtherCat Master does not show any error message and only indication of malfunction is xFC01_Rexroth_mode shows "pre-op".  All other devices in the EtherCat network showed "op".

No error message were shown other than xFC is stuck in the "pre-op" and will not transition out even after the system complete power cycle.

EFC firmware is "FWA-EFC01*-NNN-03V39-NN" and MEP fiemware is "FWAxFC01-MEP18" .

Thank you for your support and please let me know if you need further information.




In fact, Index 16#1605  and 16#1A05 has the Fixed content flags. This means you cannot add new PDO content under this index.


What you need to do is check the option for the 16#1615  and 16#1A15 index ,then you can add new PDO content  under these index, like this:


Then re-download the IO configuration, and the EtherCAT master state will be successfully switched to the op state.😉

In addition, you need to pay attention to the conversion of function codes and index addresses.