Showing results for 
Search instead for 
Did you mean: 

unable to install app of any version without error

unable to install app of any version without error

New Poster


Ive been working with ctrlX for just the last few days.  ive watched the videos and read everything i can find but have not been able to load apps onto my physical core.  I have no touble loading apps onto the virtual core.  I have attached pics of the errors i recieve when i try to install motion or plc apps. i have tried the apps 1.12, 1.16, and 1.18.  I recieve the same error each time.  is there some sort of activation or license that is required?  

My core has ubuntu core 18 and the virtual core is ubuntu 20.  what is the process to update to 20?  Is this upgrade a requirememt to use the core.



New Poster

added system report 

Long-established Member

I am afraid you are still running an OS version < 1.12. You can check by clicking show system apps in the app over view. If you are below 1.12 you need to update the OS 1st using the factory reset: See 


thanks for the response, i was guessing i was given an old unit that needed updating.  i want to confirm the procedure or make sure i am correct on the procedure.

link to procedure

which of the following files shown here contain the correct files as described in the above procedure

  • Reference to the Image Update Tool via the Collaboration Room as .zip archive (
  • Reference to the image via the Collaboration Room as .tar archive (rexroth-arch01.tar)

thanks again, i appreciate all the help getting this going! happy holidays!


New Contributor

Hi elemay,

you should only have these 3 files in your sd card for factory reset. 


Warmest regards,

Good afternoon,

Do you know how long the update process takes once the blue/red flashing lights begin?  i do not see a time called out and have an ongoing update that has not stopped the blue/red flashing for a couple hours now.  

New Contributor

Hi elemay,

Before the blue and red light flashes insert your sd card then power on the ctrlX.

It takes about 10-20 seconds for the flashing blue and red light to take place.

The update is complete when the LED is not flashing anymore in red and blue.

-LED flashes blue: Update completed successfully

-LED flashes red: An error occurred

To localize the error, use the flash.log file. The log file is stored on the microSD card in the folder created during the reset. The folder name is the serial number of the ctrlX CORE.

Community Moderator
Community Moderator

Attached the link to the official description of the image update.



thank you all for your assistance, after preparing another SD card the update was able to complete the update successfully.  the apps are now able to be installed and utilized.