Showing results for 
Search instead for 
Did you mean: 

Updating core18 Snap fails

Updating core18 Snap fails


I am trying to update the "core18" Snap package on several ctrlxCore devices. I am running version 20210611. Both, DeviceAdmin and DevicePortal offer me to update to 20230207. But updateing always fails with message:

"update: Operation failed (Code: 400)! Message: snap has no updates available, Kind: snap-no-update-available"

Other Snaps are not updating as well, but are not as urgent as this one. Tried updating in all possible ways. What am I doing wrong?

Screenshot 2023-02-24 092816.png

Screenshot 2023-02-24 092823.png


Community Moderator
Community Moderator

Can you please tell us which system app verision you are using? I guess 1.12.x.

So you tried to use the online store and load the apps by the browser to your ctrlX CORE?

It looks like you are trying to update the snaps to a version that it is not allowed to run on your system. I guess your "Version guard" app is preventing you from updating to unfitting state.


Hi and thank you for your reply.

Yes, the device was manually updated from a previous firmware version and is now running system apps version 1.12.x

No I did not try to install from the online store, I could not find these apps in the online store Can you provide a link, then I can try.

I uninstalled the "core18" package and then reinstalled with the device portal. It offered there to install "20230207", but actually "20210611" was installed again.

If later versions of "core18" are not allowed on the device by the "Version Guard", is there any way to find out what exactly is blocking the update?

Community Moderator
Community Moderator

To clear one confusion, with online store I meant the app store that can do updates via ctrlX CORE web UI connected directly to the internet or device portal. There only long term service versions of our Rexroth specific apps are accessible (currently version 1.12.x).

Other suppliers like Canonical as provider of the core and snapd apps can add all official releases that exist from their side.

We implemented the version guard app to make sure the system is in a consistent configuration, as changes coming with later versions could lead to incompatibilities. So each single app is checked while being installed. We are working on a message that points out clearer why its not working.