Showing results for 
Search instead for 
Did you mean: 

Ethernet Ip Settings lost

Ethernet Ip Settings lost

New Contributor

We cannot connect with a ctrlX core anymore, we pinging we do not get a response. This happens when changing the ip Adress of the ctrlX core. 

We're not sure if there is something wrong with the core, or that the ip Address is not in range of our router/computer. It could be that the core is on a ip address where we do not know the exact numbers.

So there's no possability yet to go online over USB on the core. Is there a tool where I can ping "all" ranges to finally find out which ip addres the Core is on ?  By the way the ctrlX core starts up green. Thats a nice coulour, but we like to go online with it. ...


Long-established Member

If you did only change the IP setting if XF10 (ETH0) you can use XF51 (ETH1) which still has DHCP enabled. CHecking the log of your DHCP server will give you the IP address. Running Wireshark filterred on DHCP messages will work too.

Community Moderator
Community Moderator

Hi Pinball_NL,

if you are directly or via a simple switch connected, you can always reach your ctrlX via the IPv6 Link-local address.

This can be calculated from the MAC address which you can find on the type plate.

Here is a link to a online calculator:



Or you go to the network explorer of your windows, here you should see the ctrlX COREs in your network as well, you may have to enable the discovery function.





This worked !  You will be remembered as a hero CodeCaptain 

Thank you! 

I can login again via the ipv6 adress. 

When looking at the connectivty settings I don't see anything strange. 

When I make changes and try to save I receive the following error: 



Do you have any clue what is the issue? Yesterday when I initially lost the ability to login via the the ipv4 ip adress I received a similar error. 


Hi RobotART_Walter,

you could check that you have all the User rights to do changes here.

Additionally you should not have IP addresses in the same subnet configured on eth0 and eth1 or further ports.

And you should have only one Gateway configured. Keep in mind, if you have a DHCP server in the network it will also assign a gateway.

I checked the user permissions but this seems al good. Everything is enabled for the current user. 

I made sure to have different subnets. However I am not able to save anything due to the error message: 



Can you please send a system report.

Via "About" --> Generate report.

Please find it attached in the zip folder. 




we are looking into the topic, in the meantime you could update to the latest deviceadmin app 1.12.3 via the online store and try again.

Sidemark, assigning the own IP, in this case, as a gateway doesn't make sense.

Have a nice weekend

I will do that. However, I am not able to find the deviceadmin app in the store/collaboration room. 

Could you share it with me directly maybe? 


Thank in advance! 

I updated the device admin app to the newest version. I also took the effort to update all system apps the the most recent version. 

When changing/saving the ethernet configuration I still receive the same error though.

Currently I can't do anything with the core because the PLC app requires an IPV4 address. So it would be nice if we can get this problem solved in short terms. 

THanks again  and have a nice weekend. 


Hi RobotART_Walter,

there is a bug in the system if once a bridge was created.

You can go around by flashing a new system image or a bit tricky like done in the attached video.

Hope this solved your problem.

This solved the issue!

i followed the video and afterwards i could save again.

Thank you!