Showing results for 
Search instead for 
Did you mean: 

CtrlX Core - Wifi dongle connection

CtrlX Core - Wifi dongle connection


I have seen that CtrlX core is able to recognize wifi dongles. Mine not. I have managed to connect ethernet adapters till now. Is there someone who can help me?

i am using a Ralink Technology, Corp. RT5370 Wireless Adapter


Community Moderator
Community Moderator

In general the ctrlX CORE can only recognize preinstalled USB devices. So there is actually a quite limited number of them also due to security reasons.

I will check this with our R&D.


Thank you very much, do you have any news?

Actually (RM20.11 V1.6.0) only USB to Network LAN-Adapter with the chip set Realtek 8153 or Realtek 8152 are supported.

In next releases it is planned to integrate an USB to CAN and to Wifi dongle. Further information will follow.

If there is a special need for a specific USB device please get in touch with us directly.

Community Moderator
Community Moderator

Hi Mauro,

good news. Wifi dongles will be supported from version 1.8 to act as a client.

Planned is to act as an access point from version 1.10.

A list with supported dongles/chipsets will be provided soon.


I have just bought the suggested dongle version: NETIS wf2123. My ctrlx (and even the others i have used) with the 1.8 update is still not able to detect it



I used the recommended "CSL – 300 Mbit/s WiFi USB Stick Adapter Stick/Wireless LAN/WiFi Dongle for PC/Mac/Linux/2T2R MIMO" with "Realtek RTL8192CU" and it worked out of the box.

Not sure if it is okay to post shop links here, but I ordered it here: but might be also available elsewhere.

Best Regards,



Can please you have a look in the Diagnosis Logbook with the following filter settings?


There you might see some messages about the why your stick is not supported or if you did some misconfigurations.

Hi Krauskopf, 

I have ordered exactly that. I have ordered another one specified as RTL8192CU, sadly i have received two RTL8192EU. Anyway bot chipset relies on the same driver. As specified DevWiki . Ubuntu has such driver already present in kernelspace by default, is running as befaulti inside the PI4 with standard ubuntu core installed. I do not have the "netplan-wpa..." entry to be filtered in the logbook. 

Is there something i can do?



Really thanks for the help. 


EDIT: after 4 wrong dongles i got a RTL8192CU from Aliexpress and it is working correctly 😎.  I still don't understand why the CE version is working and the UE is not. 


So with that USB wifi dongle I'm assuming you have a USB-A to USB-C adapter in order to plug it into the CtrlX Core?


For completeness I have a usb-A hub with type-C plug. Common USB A to type c are working correctly anyway.

Not applicable

Hi sorry to dig up this old thread,

But could you provide the supported wifi chipsets for CtrlX?

Community Moderator
Community Moderator


  • NETIS wf2123
    CSL – 300 Mbit/s WiFi USB Stick Adapter Stick/Wireless LAN/WiFi Dongle for PC/Mac/Linux/2T2R MIMO

With RM21.11:

  • TP Link TL-WN823N


Thank you for this post! It worked with me for Realtek RTL8192EU from zebronics. But didn't work with NETIS wf2123. I am using 1.20 version.

Check the chipset. The problem is that sometime the NETIS has CU chipset. like happenet to me.

Go for the TP-Link. 

Hi, I spent hours on portals trying different types of chipsets which are in shops and finally found the wifi dongle which has RTL 8192CU chipset (BTW: so far only CU version is working as AP mode) which runs in ctrlX Core X3 as AP mode and is still easy available to buy.

NW362 RTL8192CU 300 Mbps Wi-Fi Dongle  

So above wifi dongle - pls select white model NW362 300 Mbps - this is not the ad just result of my searches - is identified by ctrlX as follows

rtlwifi: -----hwsec_cam_bitmap: 0x0 entry_idx=4
rtl8192cu: Tx queue select: 0x05
rtl8192cu: MAC auto ON okay!
rtl8192cu 1-1:1.0 wlx08107b8b1073: renamed from wlan0
usbcore: registered new interface driver rtl8xxxu
usbcore: registered new interface driver rtl8192cu
ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
rtl8192cu: Board Type 0
rtl8192cu: Chip version 0x11


The WiFi AP mode works like a champ.


Thanks, x5 and x7 are supporting really more devices 😃

Established Member


This wifi dongle Dporfis USB AR9271 works with newest ctrlX V1.20 and 2.6.