Showing results for 
Search instead for 
Did you mean: 

The Modbus TCP app is currently not available

The Modbus TCP app is currently not available

New Poster

After installing the Modbus TCP 0118.0 version i recive this message, it doesnt matter how long I wait, it still remain in this state. I tried uninstalling and installing it again both same version and older versions. The message i recive is the following:

"The Modbus TCP app is currently not available (Error: 404).

This is most likely due to one of the following reasons:

  • The app is currently being initialized. This may take a while, please refresh the page.

Did anyone else encountered this problem? Can somebody help me fix it?


Community Moderator
Community Moderator

Hi bogdanserban,

what hardware do you have, and which versions of the system apps?

Do you have the correct license installed?



The hardware I'm using its a REXROTH ctrlx CORE, first i tried the version of Modbus TCP 1.18.0 and after 1.16.0, both of them had the same result.

The licenses are installed correctly.


you may upgrade your whole system to version 1.20 and try it.
This is the latest version which will also go into long term support.

The version 1.20 its not avalible for me as download resource, latest versiom that has the modbus tcp app for download its 1.18. Can i get a link for 1.20 version of this app please?

It is part of the 1.20 app package on the collaboration room as mentioned there. See FAQ for ctrlX Store for generall access information.

Releasenotes | System_Apps | 3D Viewer 3DV-V-0120.1 | Container Engine DOE-V-0118.2+20.10.17 | EtherCAT Master ECM-V-0120.0 | Firewall FRW-V-0120.0 | GCode GCO-V-0120.0 | InfluxDB IDB-V-0120.0+2.6.1 | IoT Dashboard GDB-V-0120.0+9.3.6 | Key Value Database KVD-V-0120.0 | Modbus TCP MBT-V-0120.0 | Motion MOT-V-0120.0 | Node RED RED-V-120.0+3.0.2-ctrlx | OPC UA Client UAC-V-0120.0 | OPC UA PubSub UAP-V-0120.1 | OPC UA Server UAS-V-0120.0 | PLC PLC-V-0120.0 | PROFINET device PND-V-0120.0 I Python PYR-V-0120.0 |Remote Agent RMA-V-0120.1 | Service Indicator SIN-V-0120.0 | Telegraf Server Agent TSA-V-0118.7 | VPN Client VPN-V-0120.0

Community Moderator
Community Moderator


could you please give us the serial number of your ctrlX CORE and put a screen shot of the failure message you got when you tried to install the Modbus App.