Showing results for 
Search instead for 
Did you mean: 

CodeSys Ethernet IP slave missing process data

CodeSys Ethernet IP slave missing process data

Established Member


I am trying to use the core in a standard SFK-4H to control other items beyond the SFK, like our EFCs and third party components. one of the third party components gave me some weird issues. the component is SMC Ethernet IP coupler as a slave. I downloaded the EDS file of that part and after installed in device repository as an Ethernet IP slave I could scan it and add into the project. looks everything was working( the bus showed green light on this slave). however when I opened the IO mapping there were only 1 byte in and 1byte out, but the there were showed 4 bytes out and 2 bytes in in the connets tap. see the screens.



I don't know why it couldn't show all the process data in the IO Mapping. I then tried to creat a slave as a generic device and configured 4 bytes out and 2 bytes in. it showed an error when getting onlined.


based on the error message I copied the the vendor ID and product code into the generic device. it still showed me the same error message. I found out there were using deferent connection pass between using EDS file and set as a generic device, but I wasn't able to change it. here is what it was setup



can someone test it out and tell me if there any setup I did wrong? or why didn't the number of IO mapping match the connections setting by using eds file?  I need to install more than 8 valves for SMC pneumatic system. see the eds file as attached.









Community Moderator
Community Moderator

Moved to the corresponding forum CODESYS - PLC Add-ons.

Community Moderator
Community Moderator

Is this still open? Can this topic be closed?