Showing results for 
Search instead for 
Did you mean: 

Sample Program not working with the latest version of PLC and Works?!

Sample Program not working with the latest version of PLC and Works?!

New Poster

Hi everybody

I just can' get the sample program to work with the latest version of Works and PLC. I am talking about the sample app of "Demo Kit Tutorial #7: ) 

I am getting the attached error messages...


  1. when I try to test the connection in the PLC app
  2. when I try to load the program to the Core


Does the sample app work at all with the latest versions of Works and PLC??

Thanks, Roland


New Poster

After I realized the issues were coming from "user credential bugs" on the core (I logged in a user but the system said: another user is logged in with no credentials), I removed all users from the Core: 

Still can't get even the Motion app showing up to configure/edit Axes: Error 404 showing up.

- I unsinstalled all apps (!) and reinstalled the latest Motion App: still an 404 error when i hit the Motion App:


Is there a way to reset the Core or what is going on here? Somebody please help....Thanks


I do not know what exactly is going wrong at your side. I would suggest you have an older system app version and you tried to install new ones or also new application apps (e.g. ctrlX MOTION app). In the prototype version available at the moment you have to care about correctly updating the system and the version of the apps has to fit to each other.

From the version 1.12 (RM21.11) on there is an instruction how to reset the control in the official release notes. See the chapter: "ctrlX CORE Runtime, Release Notes  -->  Important information  -->  Notes on XCR-V-0112.5"

Beware that when you are using a ctrlX DRIVEplus with ctrlX CORE the firmware of the drive has to fit.

Hi, I still don't know what you mean with "care about versions"? I am using works 1.12.4 (the latest version?!) and upated the Motion and the PLC app to the newest version (1.12 ?!) and it is still not working.. Can you please send me a little bit more detailed instructions on how to proceed with reinstallation of apps now? e.g. 

1. Resetting the Core ?!

2. Reinstall  which apps ? 

Any quick help would be appreciated

Best and quickest way would be to get in contact with your mentor of the DevelopR challenge and have a live meeting to clarify these points.

Otherwise feel free to send me a private message with your contact data so we can get in touch.