cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

Omron 1S servo (CoE Ethercat) Not working

VicmitC
Member

Omron 1S servo (CoE Ethercat) Not working

Hello,

I have been working the past weeks converting software for one of our standard OEM machines (Running on an Omron system (PLC/HMI/DRIVES/I/O) ) to the ctrlX core platform.

My initial agenda was to hijack the Ethercat network with the ctrlX core. There is some rack I/Os attached to the OMRON PLC, but I access these through Ethernet/IP to the Omron PLC (NJ501-1300).

But when I try to start everything up I get problems with the Omron servo drives (1s). The Omron servo drives are running EtherCat (CoE) as a base for communications.

I have tried the two different options for the Axis Profile

1) Servodrive_over_Ethercat
2) CANopen_Over_Ethercat

But I keep getting an error message when I try to start the axis profile (Please see attached picture). The Diagnostic logbook doesn’t give any future messages.

 

I understand the support for third-party drives such as Omron's servo drives might not yet be in place. But for us, this would be very interesting since our testing is now halted until we can get this solved.

Br,  

 

1 REPLY 1
CodeWasi
New Contributor

Re: Omron 1S servo (CoE Ethercat) Not working

Hello VicmitC,

Just to get the infos right, please confirm:

- RM2207 / Apps 1.16 in operation.

- IO Signals provided by Omron-PLC with a TCP/IPSocketcom. The nonRT behaviour is accepted.

- Drives connected directly to ECAT-Master of the ctrlX. 
    *ctrlXIO Engineering used to add the Omron drives in the ECAT config.
What about the COE adjustments which needs to be checked and setup - unfortuanlty the axisprofile setup is not yet supported editing the attributes via a dialog-screen. That needs to be done by adjusting the axisprofile attributes directly in the Datalayer. 

CodeWasi_0-1669020840452.png

 



Please have a look inhere:
https://developer.community.boschrexroth.com/t5/ctrlX-MOTION/Third-party-EtherCat-servo-drives-CiA40...

Bye

 

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist