cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

Drive does not what it should do - posrel

alink
Long-established Member

Drive does not what it should do - posrel

Hello,

the drive should do a relative positioning.

Therefore, there is a input mask for velocity, acc+dec, turns right and left. Because the drive has a gearbox (324:100) all input data should belong to the tool -> means an input speed of 2400 rpm is an engine speed 7776 rpm.

When doing this with ctrlX sometimes it seems to be right, but most of the time it looks like this - see image attached

Is it because the drive (IndraDrive MPB - FW20) is configurated for output values but ctrlX motion app for??? There is no possibility for any gearbox or something.

With the same process(function it worked well with IndraDrive MLD!

-see code for movement (function block) attached as well

-a second image of a strange thing just before doing the command itself. There is some positioning - why? no reason for that!

2 REPLIES 2
CodeShepherd
Community Moderator

Re: Drive does not what it should do - posrel

I do not completely get your problem. Could you send me a private message with your contact data so we can have look to it.

For the positioning done at the beginning, that you do no expect, in the moment you change opmode:

arAxisCtrl_gb[AxisIndex].Admin._OpMode := MODEPOSREL;

 a movement command will be create. Also in your step number 10.

alink
Long-established Member

Re: Drive does not what it should do - posrel

Issue is solved now.

Because there was an delay time after power on in parameter S-0-0206 of 180ms (although there is no brake in use and therefore the parameter is not visible), the drive started positioning with that delay time. But the control started without delay so there was a lack between control and current value. This led to a strange behaviour and the drive didn't do what was expected.

To set S-0-0206 to 0ms (no delay time) it is necessary to have set parameter P-0-2206 to 0ms as well otherwise S-0-0206 has a low limit of P-0-2206.

This concerns if using a non-Rexroth servo-engine

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist