Showing results for 
Search instead for 
Did you mean: 

ctrlX CORE: DHCP not working

ctrlX CORE: DHCP not working



like the title says, DHCP IPv4 isn't working. We tried it with a loaner, it doesn't work. We ordered two production models, got them and also tried DHCP with them, it is also not working. 

At the loaner, we could at least use a root user and when we restarted the interface with "dhclient eth0", it got an IP via DHCP.

But on the production models, we dont have a root user. Also it could not be the right way, to restart everytime manually the eth-interface.

Strange is, that IPv6 is working. But this is not the wish of our IT to use IPv6. 

BTW: If Bosch speaks about OpenSource, be open to customers and so on, Bosch should grant an root user and not just when you call/write a mail and than just for 1-2 days. It makes it hard for us right now and wastes a lot of time, to develop on/with it.

Thanks and kind regards,




Community Moderator
Community Moderator

Did you first boot up the ctrlX CORE and then connect it to the network? Or vise versa?

The root user is removed because of security reasons. With this user the whole system can be manipulated and it would be easy for attackers to do damage there.

It is also possible to get a permanent root user for development purposes. Please see this tread for a discussion about this topic.

It is permanently connected to the network and than we boot/reboot the device. Like it should be in productionstate.

Ok. We have to check that directly. Please get in contact with the technical sales support. I sent a private message to you.