cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

Core Doesn't work when it's on the network

Drelax21
Member

Core Doesn't work when it's on the network

Hello everyone,

i work with the core in our company network, because our Mqtt broker only runs on the company network.

I have the IP static, and the DHCP off.unfortunately this does not work well for long.The Node Red app, for example, accesses the Mqtt broker in the company network.this only works for a short time.After that, the core no longer works and must be restarted.I tried to operate the core without a company network, it works there without any problems.

How can I solve the problem with the network? 

4 REPLIES 4
Marc_Smaak
Established Member

Re: Core Doesn't work when it's on the network

I had this issue to in our corparate network. After a lot of debudding I found this was cause by using both XF10 (ETH0) and XF51 (ETH1) network ports and having a defafault gateway assinged to both ports. I only needed IP routability on the port connected to the corparate network and therfore removed the default gateway from the other port. If you need routability on both port I assume you can reach this by defing the correct routes in the routing tab including the desired metric.

My assumption is the OS gets confused with the 2 default gateways and sometimes tries to communicate over the wrong network interface. If you only use 1 interface make sure it has a default gatway and remove any static IP of the other interface.

Drelax21
Member

Re: Core Doesn't work when it's on the network

Hello @Marc_Smaak 

Thank you for your answer.I assigned the IP statically and also entered our gateway of the fierwall.

eth0.1.PNG

the eth1 interface is not connected.

eth1.PNG

to my wiring of the network,I go from the XF10 to a switch and my PC and the network also go to this switch

Marc_Smaak
Established Member

Re: Core Doesn't work when it's on the network

It looks okay to me, only suggestion I have is to check your PC IP settings opening a command prompt and giove the command ipconfig /all

This should should show the default gateway 192.168.140.1 and subnetmask 255.255.225.0 (e.g. /24) 

If all correct you could run MQTT explorer on your PC and connect to the broker to see if this connection is stable. If yes I see no reason the ctrlX core would not be able to keep this connection other than a faulty RJ45 cable.

Marc_Smaak
Established Member

Re: Core Doesn't work when it's on the network

Sorry subnetmask should have been 255.255.255.0 (NOT 255.255.225.0) I annotedit my message anymore probably beacuse it is marked as an answer

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist