Showing results for 
Search instead for 
Did you mean: 

cannot publish to core

cannot publish to core

Established Member


I want to publish my project to a real ctrl x core.  I have a valid license on the ctrl x core. 
However, I am not able to publish succesfully.
I have tried both via VPN and a local connection. Firewall is turned off.
The ctrl x is not automaticially found and when entering the ip and port manually and try to login (default username and password, admin and boschrexroth) I see the following message:



I have tried reinstalling the app multiple times, as per this suggestion Solved: Connect To Remote WebIQ Server Environnment Connec... (

Is there anything I am doing wrong? 



What happens when you enter in a browser on the same system WebIQ Designer is running? If it also does not show the WebIQ Runtime Manager then this should be fixed first as it means there's no WebIQ running on or it's not running on port 10123 if you have changed the port manually (which is discouraged) or there is a firewall blocking the access.

When using WebIQ 2.14 on ctrlX the automatic discovery has been disabled because of a lackup issue after some time.

This way I could actually reach it ( via http not https though). From there I could create a new user and password. And with this user I can actually load the project from the web iq designer.\

Thank you!

Just some clarification:

To be able to connect via wss:// ("Connect via a TLS-encrypted websocket connection to IP on port 10123") you'd have to do this:
- enable TLS on the default listener on port 10123
- setup and configure TLS certificates

If you'd do this this would happen:
- you could no longer connect to WebIQ on ctrlX with WebIQ Designer as it expects an unencrypted connection on port 10123

That's why you don't usually want to do that.

In TCP/IP you cannot have both HTTP/WS and HTTPS/WSS on the same port - this means that for using an encrypted connection you'd have to setup a separate listener on another port, e.g. 443, then you could connect using wss://

This also means that you should be able to connect to your system from WebIQ Designer using ws:// instead of wss://... which is probably the solution for your issue.