Showing results for 
Search instead for 
Did you mean: 

NAT to XM42

NAT to XM42

Occasional Contributor

What are the essential ports required to connect to an XM42 through a NAT? I found a security manual that lists a bunch of ports and nearly all of them appear to be essential. Are all of these essential? Link to manual. Relevant info in section 4.13.5. I have a limit of 5 and have tried many variations and none seem to work. 


Community Moderator
Community Moderator

As you already mentioned several ports are essential for several communication to different tools. I will try to get further information about your topic.

Could you describe in more detail your topology? Which data should go from where over what to whom?

Established Member

Good Morning,

They try to access the XM controller thru a NAT Router. Allen Bradley 1783-NATR.

they will move their machine to another plant but need to have access remotely. They need full access to controller and PLC.

So far they can Ping the controller and access web assistance thru the NAT device. but it fails during authentication when trying to connect thru Indraworks. we tried several ports. some in imaged below





Established Member

I have no experience with login in to XMxx controls via NAT, but for the older controls (compatible with Indraworks version 12) ports 1200 and 1210 needed to be added to the NAT rules to login to the control. In the manual those ports correspond with the Indralogic gateway. For the XM2x the manual refers to ports 1740-1742 (UDP) and 11740/11741 (TCP) for communication to the gateway - maybe these could work? 



Occasional Contributor

Latest on this, we added the gateway to the controller and were able to ping and establish a connection to the controller. When testing the connection in Indraworks it was all good. However, when trying to go online/login we got the following error after entering our credentials (which work on the local network).


We could access web assistant remotely amongst other things. There must be some port missing or something else. Again, here are the ports:


Any ideas on what we could be missing here?