Showing results for 
Search instead for 
Did you mean: 

ctrlX PLC app (2.4.0) WebVisu license issue with Virtual Device

ctrlX PLC app (2.4.0) WebVisu license issue with Virtual Device



I installed RM23.11 (ctrlX WORKS 2.4.1) and upgraded the Motion and PLC Apps to the latest version, but after I updated my old PLC project made with RM23.07(ctrlX WORKS 2.2.2) to the profile 2.4.0, revising the syntax changes and tried to run the project in the Virtual Device, I ran into the license issue as shown below.


I understand this is a known issue and there is workaround as mentioned below, yet it didn't work in my case and after some investigation, I found that it seems to be related to the WebVisu.


Below is how I verify if the assumption is true:

- Created a completely new project and made a simple program


- Create an "Visulization" object with only one Checkbox element


- Add the "Visualization Manager" and the "WebVisu" object with below settings

TSY1BOX_5-1709309274910.png  TSY1BOX_6-1709309290641.png

- "Clean all" -> "Generate Code" -> "Login", then the issue will occur

Yet if I only created the "Visulization Manager" but there's no "WebVisu" added, there won't be such issue.


Not sure if this is a known issue or I just made some stupid mistake, yet it would be much appreciated if anyone could sahre any information.


I've also attached my project for reference, thanks in advance.








Community Moderator
Community Moderator

Moved to corresponding sub forum CODESYS - PLC Add-ons.

The licensing error in version 2.4 is triggered from a various reasons, also not related to the licenses. Please check if the compiler is showing any errors before trying to download. As the WebVisu compiler is way more restrict then the internal visualizations one.

When trying to update an old project you can try to remove the visualization manager and insert it again with standard settings.

Hello @CodeShepherd,

Thank you so much for the fast reply.

I've checked and confirmed that there's no any compile error.

Also I've tried the suggested solution but regardless of updating of an old project or starting a completely new project, the issue always occurs if there's a WebVisu object created.


Thanks for the advices, I hope the licensing error would be solved soon. 🙂