Showing results for 
Search instead for 
Did you mean: 

Server connection interrupted WebIQ-Designer

Server connection interrupted WebIQ-Designer

New Poster


we are working on a Projekt for controlling a robot with a CtrlX Core.

Unfortunately, there is a problem with the WebIQ Designer desktop application. The Designer starts, but is interrupted by a notification pop-up, so that no login can take place. I have attached the error message "Server connection interrupted", which occurs when the Designer is started and cannot be confirmed.

The WebIQ Designer program has already been uninstalled and reinstalled several times, unfortunately without success. For better troubleshooting I have attached the server log as txt an further information (WebIQ Runtime Version: 2.14.3).

Questions gladly

Many thanks in advance

With kind regards


Frequent Contributor

Can you please provide a screenshot of the customized shortcut you created used when connecting to your ctrlX system with the full execution path visible?

There are several causes for this:
1. Wrong IP address in the shortcut (not
2. WebIQ on ctrlX does not run on port 10123 due to changed port (doesn't seem to be the case)
3. Local firewall on the system blocking access to your ctrlX from WebIQ Designer
4. Firewall on the network blocking access from WebIQ Designer
5. ...

Also, you did not mention whether it worked before or if it never worked? The error message simply indicates that WebIQ Server was unable to connect to WebIQ Server - nothing more, so this is what needs to be investigated and fixed.

If all of the potential causes mentioned before were checked and are not the reason please provide an updated log file in trace mode (you can configure this in Runtime Manager). You should also update to the latest WebIQ version to see if the issue occurs there in that case.

Please also note that you have to use WebIQ 2.14.3 on your local system - you cannot use a different version. Providing the Designer logfile would also be very helpful, because this is the one reporting the connection error.


Community Moderator
Community Moderator

When downloading WebIQ from Rexroth Store, there is a document "Insatllation and Licensing setting for ctrlX CORE", this document explains the special setup of WebIQ when running it on ctrlX. Reading your description, it sounds to me, that you didn't do the setup correct.



I have no customized shortcut created, but i already downloaded the .txt file from the WebIQ Website. What should I do with it?

I checked all four solution proposals but nothing has changed. (atteched file: Listen_ports.png)

Futher I updated the WebIQ server and runtime on the CtrlX and the designer on my computer, both to 2.15.9.

I send you the actual server log. But i have no possibility to get the designer logfile, because of the notification "server connection interrupted".

How can I bypass this notification to login and configure the designer?

With kind reguards

Hello @BernhardKausler ,

The WebIQ designer shortcut needs to have some flags applied to the target. Here is an example for the target ctrlX CORE WebIQ runtime server at The flags must be updated if the runtime port or IP address are changed.


The flags after the executable path are what need to be added.

"C:\Program Files\WebIQ\Designer\webiq-designer.exe"  --ws-host= --ws-port=10123 --user-data=webiq-designer192.168.1.100-10123


Frequent Contributor

Another quick note: the default IP is for the listener and should usually not be changed, because this simply means "listen on all interfaces":

If you enter an IP here that the system cannot bind to (because it doesn't have that address) the server will not start which means that you cannot fix the issue in Runtime Manager, because the server is not running.  Entering anything other than for the listen IP will only restrict the listen interfaces, not extend or fix anything. If you set it to and you change the IP address of the ctrlX is will also not works anymore - with it will work.

In your case seems to be correct, I just wanted to point out that changing to any other IP is a restriction and might cause the server to not start anymore, because the OS does not allow binding to an IP that it does not have.


Thank you very much this solved my Problem. The flags were not correct in my shortcut.

With kind reguards

At Rexroth store download page of WebIQ there is a document describing the creation of the short cut as described above.

The new WebIQ version 2.16 comming hopefully in a few weeks, includes a new feature to enable you to connect to remote system ctrlX. This means the manual setup of the start short cut is not necessary anymore.