Showing results for 
Search instead for 
Did you mean: 

ctrlX Works : Virtual control Failed to sync vcpu reg

ctrlX Works : Virtual control Failed to sync vcpu reg

New Poster

Hello ,


ctrlX Works WRK-V-0116

When starting to run VirtualControl-1 we get the error "Failed to sync vcpu reg" and VirtualControl-1 goes to Offline .


Community Moderator
Community Moderator

Could you please give some more information:

Which operating system are you using?
Do you use an HP computer? Because we know that some HP software tool cause that behaviour.
Did you install ctrlX WORKS in a operating system under VirtualBox?


i am facing the same problem as the original poster. When trying to start the App Build Envirement, i get the error message "Failed to sync vcpu reg" (see Pictures).
Yes I am using an HP ZBook and I installed Ctrlx WORKS on the host Windows 10 Enterprise Version 10.0.19044

Any help is appreciated.



Established Member


We had the same problem on another PC, here is the solution for this PC:
On the PC there was running a software called HP-ShureClick. This is software that encupsulates some applications running in virtualized environments, and therefore the virtual cpus could not be used by INTEL HAXM.
Workaround: Start the virtual control without any hardware acceleration (is too slow)
Or: as described in

HP SureClick is a security protection program which runs "unsafe" programs in micro-VMs. It may also be called HP Wolf Security on your machine, which is the new name for it, although under the hood (e.g. folders, dialogs etc) it's still called SureClick. It may have some processes visible in Task Manager with a prefix of "Br", which stands for Bromium.
Similarly to other answers, it cannot be running at the same time as Android Emulator, as it is basically a virtual machine.
Here are some steps to disable it (not all may be required but this worked for me):
1. Right click on "HP SureClick" or "HP Wolf" in your system tray and select "Disable Threat Containment". It will pop up a dialog asking for the reason (optional), so just click OK
2. Right click on the icon again and select "Disable Malware Protection"
3. Click Start, type "services", open the Services window and set all "HP SureClick" services to disabled by right-clicking on each -> Properties -> change startup type to Disabled (for me there were 3 such services)
4. Restart the computer
After doing this, I was able to start a virtual control with INTEL HAXM Hardware Acceleration 🙂