Showing results for 
Search instead for 
Did you mean: 

Telegraf - Requesting data of subscription failure

Telegraf - Requesting data of subscription failure

New Contributor

Hi all, 

I am sending PLC values to InfluxDB and for that I am using Telegraf. At the beginning it works fine, but after some time (sometimes after minutes, other after some hours) I receive the message "[inputs.ctrlx_datalayer_sse] Requesting data of subscription 0 failed, got end of sse data input". I receive the following message in the diagnostics log:

Requested data failureRequested data failure

I have tried to change the interval to make sure if it is a problem of having a too high flush or input interval, but it does not change anything. 

I have also tried to replicate this by just reading the in the Data Layer the following node:


Unfortunately I have the same problems. This is the Telegraf configuration so that you can replicate it:

urls = [""]
token = "token"
organization = "boschrexroth"
bucket = "boschrexroth"
insecure_skip_verify = true

## Hostname or IP address of ctrlX CORE
## example: hostname = "localhost" # Telegraf is running directly on the device
## hostname = "" # Connect to ctrlX CORE remote via IP
## hostname = "" # Connect to ctrlX CORE remote via hostname
## hostname = "" # Connect to ctrlX CORE Virtual from development environment
hostname = "localhost"

## Authentication credentials
username = "username"
password = "password"

## Use TLS but skip chain & host verification
insecure_skip_verify = true

## Timeout for HTTP requests. (default: "10s")
# timeout = "10s"

## Create a ctrlX Data Layer SSE subscription.
## The name of the measurement. (default: "ctrlx")
measurement = "metrics"
sampling_interval = "200ms"

## Define an array of nodes with field name and node address
{name="cpu_usage_percent", address="framework/metrics/system/cpu-utilisation-percent"}

I am using Telegraf 1.18.5 and the ctrlX CORE is also with the latest version: 1.18

Thank you very much in advance. 

Best regards,



Occasional Contributor

Hi Nicolas, 

Thanks for the detailed report! I was able to reproduce the error message. I will forward the issue for further clarification. And will come back to you when I got news. 

But even if the error gets thrown, the error message does not seem to have an effect on the collecting of the data by telegraf. 

Best regards, 


New Contributor

Dear Nick,

Thank you very much for your quick reply. 

Unfortunately it is not just only a message error but also affects in the data collecting. When I check in InfluxDB the collected data at the time of failure, I see that data has not been collected. Sometimes it does not collect data for 500ms or for 30s. The good thing is that after the failure it starts to collect data again automatically.

Best regards,