Showing results for 
Search instead for 
Did you mean: 

downloading a new dashboard node from palette manager of node-red into CtrlX

downloading a new dashboard node from palette manager of node-red into CtrlX

Established Member

I have node-red app installed and licensed in a CtrlX core. it works. however when I tried to load a new node of "node-red-contrib-ui-led" I got an error of failed to install that node. then I viewed the log file into the details and got this message

see the attached log file. it looked like internet connection or setup issue.
here is what and how I have tried to make it work.
1. used it in the office. I have been using a company issued laptop and had the ctrlX( connected to the internet port( of the laptop and used wifi to get internet didn't work. then I set up a port forwarding for WIFI to use the fixed same IP address of WIFI(a different IP addess range). it did not work as well.
2. based on some suggestions from google I set the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0'. it still didn't work.
3. I tried to do the same at home and got the same error. then I set the IP addessed of CtrlX core and laptop to the same range of internet WIFI router at home and had two devides connected to the router directly. also switched off the VPN and turned on DHCP for the ipv4 of eth0. it didn't work. 
is the laptop setting blocking the registry website? what would be the best way to set the system and get a node downloaded? please let me know if there is a way to get it worked in the office since in the future we will mostlikely to support a customer from the office.

Community Moderator
Community Moderator


I was not able to reproduce your error. I connected the ctrlX CORE to a free internet (not company controlled) and connected with my laptop to the ctrlX CORE and was able to download the palette "node-red-contrib-ui-led" you mentioned. 

I would suggest to look at the time settings of your ctrlX CORE, please check if your time is set correctly. The time has to match with the server time. This is also mentioned in the troubleshooting part of the node-red-contrib-ctrlx-automation

Best regards,