cancel
Showing results for 
Search instead for 
Did you mean: 

User database is not transferred correctly after applying the setup

User database is not transferred correctly after applying the setup

Venzi_
Member

Hi,

after applying setup I got errors regarding adding users failed. In fact, users were added, but the permissions are missing and passwords not transferred. When setting a new password "Bad request (400)" error appeared. After several trials/reboot the user database seems OK again.

Not sure whether it is related to Bug 612377 and how to avoid it. Source and target CPUs  are running with X3_System_Apps_RM 23.03.5 (BF1 HW index)

Thanks,

Venzi

4 REPLIES 4

CodeShepherd
Community Moderator
Community Moderator

As your error tells:

"HTTP client error
Bad request (400) • Invalid TokenValidity, The time a session stays open should be a positive value smaller than 3124224000 (inseconds) - 080E0200 - OC7A0202"

What is the setting in your session policies for the token validity?

Mentioned bug should already be fixed as mentioned there.

 

The same error came also in the web interface during an active session (my second picture).

The settings in the session policies are beiing overwritten during the setup application.  I tried with factory default settings (0/480/0/0/3) and with my settings (0/0/0/0/3) in the target and/or source machine before applying the setup. Result was the same.

Venzi__0-1698392165407.png

 

CodeShepherd
Community Moderator
Community Moderator

Would it be possible to add your setup archive here or send it to me in a private message so we could have a look to it?

Which app versions were installed when creating the setup and which one before applying it?

We followed up this topic internally and planned to implement a solution in the version 2.6 of our ctrlX OS. We are also checking for adding this as a patch to version 1.20 but I do not have a date for this.

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist