Showing results for 
Search instead for 
Did you mean: 

I uploaded an invalid APP and now I am unable to delete it or install a valid one

I uploaded an invalid APP and now I am unable to delete it or install a valid one

Occasional Visitor

Hello all,

I am new with CtrlX, just started working with one physically today.

The first task I attempted to do was to install Firewall and VPN APPs. I have downloaded both from Collaboration Room.
I have watched a video about installing Apps and I have noticed that the Apps show up in .app extension.

This confused me since the ones I have downloaded from Collaboration Room have ".app.tar" extension. Since inside the tar only a folder was found, I have decided to simply removing the ".tar" extension in the file, leaving with only ".app".

I have uploaded to my CtrlX core local storage and he accepted it just fine.

Unfortunally, something seems to have gone wrong. Although the app shows up in local storage tab, no versions are found in the menu:


Also, if I attempt to install it, I get an error


The obvious conclusion is that I have made something wrong.
After a little bit more investigation, I have attempted to install the ".snap" file directly (found inside arm64 folder). Yet, this error shows up:


I don't find any option to delete the App that I uploaded incorrectly and, from what I read in this forum, there is no easy way to perform a Factory Reset. I have no idea how to get out of this situation and install my Apps to start some development.

Hope some soul can help me here. Thanks in advance!




Community Moderator
Community Moderator

Hello asergio

First of all what version you have downloaded from the Collaboration Room? (RM21.11 or V1.12.x?)

Second the Firewall up don't appers in the menue list at the left side. You can find it under settings.



To deinstall the app again you have to go into the app menue. Here you can click on the app and after switching to "Service mode" you can unistall it.



Established Member

Hi asergio,

i suspect that you tried to install the 1.12.0 versions on a 1.10 base system. Could you please show the versions of the system apps?

Assuming I am correct: There has been a major change from 1.10 to 1.12 in regard to Ubuntu Core. Instead of Ubuntu Core 18, 1.12 is based on Ubuntu Core 20 - and this also applies to the non-system apps. Therefore, all apps >= 1.12  won't run out of the box on an 1.10 system (and vice versa - 1.10 apps also won't run on 1.12 systems out of the box). When you try to install an app without core18 / core20 (the core OS snap of 1.10/1.12) being installed, you will get the (kind of misleading) error message that you have attached. The only workaround for your situation I know of is to download the core20 snap (e.g. by connecting the device to the Internet). Nevertheless, this might have non-desirable effects and I do not recommend it.

I strongly recommend to update to 1.12, first. Unfortunately, you will have to use the Image update mechanism, because there have been breaking changes between both versions. Please contact your spokesperson for details about the Image Update.

Future updates (e.g. 1.12 - > 1.14, etc.) will be able via App Update again.

your spokesperson for details about the Image Update.

Best regards


Hello Michael,

Thank you for the answer (and sorry for my late reply, I have been trying to recover my original account but with no success, so I created another).

You are totally correct, I have tried with older versions of the App and it worked great. I have started to suspect of being related with my system version. Yet, to try to understand this issue, I have tried to update my system but the instructions are unclear about where to figure out what is my current version. Can you point me to where I should find this information?

Just to add - on my original post I referenced that no version shows up on the App page, but I later found out that it was a visual bug with Edge and Internet Explorer. As soon as I tried with Firefox it worked out great.

It is not possible to update the ctrlX CORE system by single app updates from version older then 1.12 to this version because there was a lot of refactoration of internal storage system.

Please have a look to the official release notes to see how to do the update vie an image.