Showing results for 
Search instead for 
Did you mean: 

Backup problem

New Poster

Backup problem

I tried to backup my CtrlX and and I ran into this problem:


What I should do to backup the system?

In my system I have a CtrlX core, a S20 Ethercat coupler for the IOs and a HCS01. I would like to know if when I backup I also save the parameters from the HCS01, the configuration of the Ethercat master and also the compiled program of the PLC?


Long-established Member

Re: Backup problem

What app-version to you use? (Solution, plc, system-apps, ...)

For test can you please create a new configuration, activate this new (emtpy) configuration and run the backup again. To see if the same error occure?


The backup will save all data of the CORE. Means

  • motion config
  • plc program (compiled, source if available on the core)
  • IO config

But not the drive parameter.


Established Member

Re: Backup problem

I've got the same problem with the same failure message. I'm using the following app version:

  • automation core = 1.8.2
  • core = 16-2.49.2
  • core18 - 20210309
  • solutions = 1.8.1
  • snapd =
  • plc = 1.8.1
  • motion = 1.8.1
  • ...and a lot more app with latest version

Sorry, I was not able to generate a system report ("Fehler - Serverfehler" inside google chrome is coming. Within Firefox nothing happens when I want to generate the system report).

I did some tests:

  • Activate a new (empty) configuration -> I get the same result
  • stop the scheduler -> I get the same result


Tags (2)
Long-established Member

Re: Backup problem

Maybe there are to many apps loaded into the local storage. Please delete all apps in the local storage and try the backup again.



Established Member

Re: Backup problem

I deleted all the apps and now I get a other error:

operation failed with error 'Save snapshot failed after 10 retries' at state: 'create snapshot set'



Long-established Member

Re: Backup problem

If the snap data is changing during the backup, the procedure rerpeat read the snap-data again. After 10 retries the backup will be aported.

Please repeat the backup in case no axis is moving.

Other points to check if the same backup error message appears again:

  • switch the motion-app to state configuration
  • switch ethercat-app to state init
  • switch the sheduler to state configuration
  • stop the plc program