cancel
Showing results for 
Search instead for 
Did you mean: 

Error while Importing Project

ariamalikh
Member

Error while Importing Project

Hello everyone,

I created a sample project for a customer, exported this project, and send it to this customer.

Unfortunately, they couldn't open the project and got an error message (see picture). Does anyone know how to fix this?

PS: I tested the import in my WebIQ Designer and it worked flawlessly

Thank you in advance

6 REPLIES 6
webiq-sk
Occasional Contributor

Re: Error while Importing Project

Is the customer's WebIQ Designer also connected to a ctrlX CORE or is he just using his local WebIQ Designer instance? How large is the project ZIP file?

Can you please send me these files via PM from his system? 

%PROGRAMDATA%\WebIQ\connect.log
%APPDATA%\webiq-designer\designer.log

 

ariamalikh
Member

Re: Error while Importing Project

I am using WebIQ Designer, which is connected to my ctrlX CORE, and the customer is using a stand-alone WebIQ Designer on their local laptop. The zip File is only 3 MB.

webiq-sk
Occasional Contributor

Re: Error while Importing Project

Thank you for the log. Here are the relevant error messages from the connect.log:

[2022-08-29 06:47:13.379324] [ error | websocket] read failed!
[2022-08-29 06:47:13.379324] [ error | websocket] error_code(): asio.misc:2:End of file
[2022-08-29 09:10:19.090152] [ error | http] read failed!
[2022-08-29 09:10:19.090152] [ error | http] error_code(): generic:104:bad message
[2022-08-29 09:10:41.076216] [ error | http] read failed!
[2022-08-29 09:10:41.076216] [ error | http] error_code(): generic:104:bad message
[2022-08-29 12:41:23.440984] [ error | websocket] read failed!
[2022-08-29 12:41:23.440984] [ error | websocket] error_code(): asio.misc:2:End of file

[2022-08-26 08:33:18.664514] [ error | http] read failed!
[2022-08-26 08:33:18.664514] [ error | http] error_code(): beast.http:12:bad method

[2022-08-26 08:21:31.590251] [ error | project] Project '28c36643-364f-4643-abcb-637268caf9b3' failed to load.
[2022-08-26 08:21:31.590251] [ error | project] what(): Failed to load required data recorders

Possible reasons might be:

  • no space left on disk c:
  • interfering local firewall/anti-virus software

Recommendation:

  • check available disk space on c: and free space if none is left.
  • temporarily disable all local firewall and anti-virus software 

Does this solve the issue?

ariamalikh
Member

Re: Error while Importing Project

Thank you for the reply.

Unfortunately, it didn't work. There is still much space in the c: dir available and the customer only have a standard windows firewall (and anti-virus), which are deactivated during the tests.

They also tried to start WebIQ Designer as admin. It didn't work too.

Do you have any other ideas? Maybe it makes sense to have a call and check the settings.

Thank you in advance.

webiq-sk
Occasional Contributor

Re: Error while Importing Project

Can you please do the following on the affected system?

1. Restart the system
2. Download and unpack Process Monitor from https://docs.microsoft.com/en-us/sysinternals/downloads/procmon
3. Stop all background programs (also non-essential background programs in the task bar info area, but keep WebIQ services running)
4. Start Process Monitor (Procmon64.exe)
5. Options -> Profiling Events: check "Generate thread profiling events" and "every second"
6. Stop capture (if active already):

 
webiqsk_1-1661854342065.png
Then click on the trash can to delete the recorded data

7. Start capture by clicking on the button
8. Launch WebIQ Designer
9. Try to provoke the error
10. Wait a few seconds after the error occurred
11. Stop capture
12. File -> Save with default settings, save e.g. in the Downloads folder
13. ZIP the .pml file that was created and send it via a PM to me (please do NOT post it publically here)

webiq-sk
Occasional Contributor

Re: Error while Importing Project

After providing the data and project I can now also reproduce it directly. The reason is that the project ZIP file contains invalid data - I assume this has been packed manually instead of downloading the ZIP file directly from WebIQ Designer?

The .db directory contains another .db directory (which should not cause an issue), however the main .db directory also contains a directory named "C:\Users\haa1fc\AppData\Roaming\webiq-designer\workspace\.db\db.sqlite3"

WebIQ Server runs as a system service having no access to C:\Users\haa1fc. But when you unpack a ZIP file with a file named c: it tries to unpack there.

Can you please explain how you created the ZIP file?

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist