Showing results for 
Search instead for 
Did you mean: 

The AMD64 snap is working on virtual core but ARM64 snap not on the core

The AMD64 snap is working on virtual core but ARM64 snap not on the core


I created a snap with amd64 arch and deployed it on the virtual core. The app is running as expected.

Now when we tried to deploy the it in the core (arm64) the snap is not initializing. I'm getting this messege.

Screenshot 2023-09-13 112312.png



I checked the logbook and tried to find the unit which also I cannot find. Do you know what might be the reason?


-app is a fastAPI server

-I am getting this warning frequently: Trace warning web.common.logger;;Failed update status: failed to update the status on device portal. Error: Patch "": dial tcp: lookup Temporary failure in name resolution



Community Moderator
Community Moderator


it seems like you were not able to crossbuild for the arm64 architecture properly. Can you give me some more information on your snap? 

Which SDK-sample did you use? Which programming language did you use? How did you build it?

You can also filter in the logbook for the log messages for your snap (filter: unit). Please have a look, here if you can see some logs. 


Best regards, 


Occasional Contributor

If you have SSH access, I'd suggest restarting your snap and watching the logs on startup.

Ex: sudo snap restart ctrlx-node-red; sudo snap logs -f ctrlx-node-red

I used python for the snap. and arm64 was built using the shell script in other examples. In the log I cannot find the unit for my snap. I can share the snap log if you wan to take a look.

Here is the log of the snapcraft. And Im adding the yaml file for your reference.

Community Moderator
Community Moderator

I think the problem comes with some python libraries you are using, which are difficult to cross compile. 

Have a look at this post from @MauroRiboniMX, he already explaind the issue: Community Post - Python install packages.

Best regards, 



Python cannot be cross compiled. so if you use purely "interpreted" libs then it works otherwise not.
It is a snapcraft problem and not a ctrlX deficit. Which libs are you using by the way?

cross compile python 

i am using following libraries: python-packages:
- wheel
- requests
- flask
- fastapi
- uvicorn
- pydantic
- pyomo
- networkx
- pandas
- typing


among these which would bw the ones that need to be modified?

Try to remove pandas. i think that this could be the problem. Anyway better if you run a simple script with just flask and then try to add the libraries one by one. 

Edit: also pydantic has this problem. check here: