Showing results for 
Search instead for 
Did you mean: 

ctrlX Drive PROFINET communication issue

ctrlX Drive PROFINET communication issue

Established Member

Trying to add a ctrlX drive with enough data to a Profinet master does not work. In picture one everything is ok and the profinet master finds the correct modules in the drive and profinet communication can be established.


In picture two, one 4 byte parameter is added to the drive mdt, and the master does not find the input module anymore. The profinet communication can not be established. Am I missing something or is this a feature of the system?





Also a question on the forum about examples for Siemens PLC has been asked and the answer was examples will be made when there is enough interest from customers. Well at least in our country unit there is interest and a lot of usage of our drives behind Siemens masters.



Long-established Member

Hello this is actaul a runtime bug.

We expect the new runtime in the next two weeks ( new AXS03V08-NN.02 fixed this issue).


General important hint for Profinet with CtrlXDrive runtime AXS03V08-NN.00:

à   Actual max. 9 parameters works as process data, not more!!


Long-established Member

One more information, if you need a example (function bloc) then contact the application group via mail.

Actual there is a preversion (prototype) available, the official version we expect end of juli.


Established Member

Test continues... With newer firmware adding enough parameters makes profinet unwork again.

Firmware: FWA-XD1-AXS-V-0312N-NN.00


EDIT: False alarm. There must have been something else, because now it is working.

New Poster

Has the problem  been solved? Is it ok to use version 0312?

Long-established Member

The actual official version is

Firmware: FWA-XD1-AXS-V-0308N-NN.03

this version works on customer side.

What is you actual error, issue with profinet?

We need master information (used GSDML file, master PLC Siemens?) and parfile drive (all parameters).

My ctrlx drive version is FWA-XD1-AXS-V-0308N-NN,TIA version is 1.16.Actual 11 parameters is working,not more!

Is the problem solved about the limit of the process data on the version 0312?

Long-established Member

Firmware: FWA-XD1-AXS-V-0308N-NN.03 ?

I miss information, parameter file, see my last post.