cancel
Showing results for 
Search instead for 
Did you mean: 
SOLVED

adjust Maximun packet size in the parameter list

AndroidzZ
New Contributor

adjust Maximun packet size in the parameter list

Hello,

In my application, we want to adjust the maximum packet size we can send to the mqtt broker to 128KB. I found that the current packet size is 4096. See image (maximum packet size). I have tried to adjust this parameter, see highlighted part in the other image (adjusting packet size), but I constantly get an [AccessViolation] from the "CheckPoint" function. see image acces violation.

Does somebody has an solution on how to adjust this packetsize?

I am using the MQTT and the AWS IOT CORE library.

Kind Regards

5 REPLIES 5
eschwellinger
Established Member

Re: adjust Maximun packet size in the parameter list

Hi,

could we get projectarchive to investigate this?

I would propose to open a bugreport in the CODESYS store -> my question.

Thanks and kind regards

AndroidzZ
New Contributor

Re: adjust Maximun packet size in the parameter list

Hello,

I have archived the project and send it in the attachment.

Kind regards

eschwellinger
Established Member

Re: adjust Maximun packet size in the parameter list

possible to use latest versions of the libs and give them a try?

VersionInfo.jpg

AndroidzZ
New Contributor

Re: adjust Maximun packet size in the parameter list

I just installed the latested IIoT package with the latest library versions but that didnt help.

AndroidzZ_0-1668169307847.png

 

eschwellinger
Established Member

Re: adjust Maximun packet size in the parameter list

The AWS client is configured incorrectly.

You use a MQTT V5 property (which is not passed to the client) to set the max. payload size. This only exists for the MQTT client and in the case of MQTT V5 and is an info for the server (also says so in the help).
Seems that you use the Maximum Packet Size to inform the server that it will not process packets exceeding this limit.
The maximum packet size and the maximum payload size can be edited via the MQTTParam parameter list of the MQTT Client SL library at toplevel in the Library Manager. (see attached screenshot)
AWS IoT Core does not support MQTT V5
It's a bad idea to always transfer the maximum payload. see Publisher udiPayloadSize:= SIZEOF(GVL.wsJsonData).
It would be better to transfer the current length of the string.

Icon--AD-black-48x48Icon--address-consumer-data-black-48x48Icon--appointment-black-48x48Icon--back-left-black-48x48Icon--calendar-black-48x48Icon--center-alignedIcon--Checkbox-checkIcon--clock-black-48x48Icon--close-black-48x48Icon--compare-black-48x48Icon--confirmation-black-48x48Icon--dealer-details-black-48x48Icon--delete-black-48x48Icon--delivery-black-48x48Icon--down-black-48x48Icon--download-black-48x48Ic-OverlayAlertIcon--externallink-black-48x48Icon-Filledforward-right_adjustedIcon--grid-view-black-48x48IC_gd_Check-Circle170821_Icons_Community170823_Bosch_Icons170823_Bosch_Icons170821_Icons_CommunityIC-logout170821_Icons_Community170825_Bosch_Icons170821_Icons_CommunityIC-shopping-cart2170821_Icons_CommunityIC-upIC_UserIcon--imageIcon--info-i-black-48x48Icon--left-alignedIcon--Less-minimize-black-48x48Icon-FilledIcon--List-Check-grennIcon--List-Check-blackIcon--List-Cross-blackIcon--list-view-mobile-black-48x48Icon--list-view-black-48x48Icon--More-Maximize-black-48x48Icon--my-product-black-48x48Icon--newsletter-black-48x48Icon--payment-black-48x48Icon--print-black-48x48Icon--promotion-black-48x48Icon--registration-black-48x48Icon--Reset-black-48x48Icon--right-alignedshare-circle1Icon--share-black-48x48Icon--shopping-bag-black-48x48Icon-shopping-cartIcon--start-play-black-48x48Icon--store-locator-black-48x48Ic-OverlayAlertIcon--summary-black-48x48tumblrIcon-FilledvineIc-OverlayAlertwhishlist